Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Avro, mail # dev - Re: Build failed in Jenkins: AVRO-python #295


Copy link to this message
-
Re: Build failed in Jenkins: AVRO-python #295
Miki Tebeka 2012-05-20, 20:59
Can someone with access to the build slave(s) "sudo easy_install urllib3" there?

On Sun, May 20, 2012 at 12:21 PM, Apache Jenkins Server
<[EMAIL PROTECTED]> wrote:
> See <https://builds.apache.org/job/AVRO-python/295/changes>
>
> Changes:
>
> [thiru] AVRO-1026. Add namespace support to C++
>
> [thiru] AVRO-1095. C++ compiler warns about control reaching end of doAdavance (in JsonIO.cc) which returns something other than void
>
> ------------------------------------------
> Started by an SCM change
> Building remotely on ubuntu4 in workspace <https://builds.apache.org/job/AVRO-python/ws/>
> Reverting <https://builds.apache.org/job/AVRO-python/ws/trunk>
> Updating https://svn.apache.org/repos/asf/avro/trunk
> U         lang/c/src/errors.c
> U         lang/c/src/CMakeLists.txt
> U         lang/c/README.maintaining_win32.txt
> A         lang/c/cmake_avrolib.bat
> U         lang/c/INSTALL
> AU        lang/c/cmake_avrolib.sh
> U         lang/c/CMakeLists.txt
> U         lang/c++/test/unittest.cc
> U         lang/c++/test/AvrogencppTests.cc
> U         lang/c++/impl/Schema.cc
> U         lang/c++/impl/avrogencpp.cc
> U         lang/c++/impl/NodeImpl.cc
> U         lang/c++/impl/Compiler.cc
> U         lang/c++/impl/ValidSchema.cc
> U         lang/c++/impl/Validator.cc
> U         lang/c++/impl/Node.cc
> U         lang/c++/impl/json/JsonIO.hh
> U         lang/c++/impl/json/JsonIO.cc
> U         lang/c++/api/NodeConcepts.hh
> U         lang/c++/api/Node.hh
> U         lang/c++/api/Schema.hh
> U         lang/c++/api/Config.hh
> U         lang/c++/api/NodeImpl.hh
> A         lang/c++/jsonschemas/tweet
> U         lang/c++/CMakeLists.txt
> U         CHANGES.txt
> At revision 1340806
> [py] $ /home/hudson/tools/ant/latest/bin/ant -file build.xml test
> Buildfile: <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build.xml>
>
> init:
>
> build:
>     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/src/avro>
>     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build>
>     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/scripts>
>     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/test>
>
> test:
> test_datafile.py
> test_io.py
> test_ipc.py
> test_protocol.py
> test_schema.py
> test_script.py
> Modules: 'test_datafile','test_datafile','test_io','test_ipc','test_protocol','test_schema','test_script'
> Non-null modules arg. creating script
> pythonpath: <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/src>:<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/test>:<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/lib>
>  [py-test] Traceback (most recent call last):
>  [py-test]   File "<stdin>", line 2, in <module>
>  [py-test]   File "/usr/lib/python2.6/unittest.py", line 816, in __init__
>  [py-test]     self.parseArgs(argv)
>  [py-test]   File "/usr/lib/python2.6/unittest.py", line 843, in parseArgs
>  [py-test]     self.createTests()
>  [py-test]   File "/usr/lib/python2.6/unittest.py", line 849, in createTests
>  [py-test]     self.module)
>  [py-test]   File "/usr/lib/python2.6/unittest.py", line 613, in loadTestsFromNames
>  [py-test]     suites = [self.loadTestsFromName(name, module) for name in names]
>  [py-test]   File "/usr/lib/python2.6/unittest.py", line 576, in loadTestsFromName
>  [py-test]     module = __import__('.'.join(parts_copy))
>  [py-test]   File "<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/test/test_ipc.py",> line 26, in <module>
>  [py-test]     from avro import ipc, txipc
>  [py-test]   File "<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/src/avro/ipc.py",> line 20, in <module>
>  [py-test]     from urllib3.connectionpool import HTTPConnectionPool
>  [py-test] ImportError: No module named urllib3.connectionpool
>
> BUILD FAILED
> <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build.xml>:130: Test execution failed.  See output for details.