Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase, mail # user - Re: Hbase 95 on Hadoop 2. No master znode created in zookeeper


+
Ted Yu 2013-10-10, 17:52
Copy link to this message
-
RE: Hbase 95 on Hadoop 2. No master znode created in zookeeper
Tianying Chang 2013-10-10, 17:59
Not really. Because we are deploying hadoop2+hbase95 in our production cluster. Need to confirm 95 is working fine.

-----Original Message-----
From: Ted Yu [mailto:[EMAIL PROTECTED]]
Sent: Thursday, October 10, 2013 10:52 AM
To: [EMAIL PROTECTED]
Subject: Re: Hbase 95 on Hadoop 2. No master znode created in zookeeper

Can you try newer release such as 0.96.0 RC4 ?

Here is what I got from 'hbase zkcli' using 0.96.0 cluster :

] ls /hbase
[meta-region-server, backup-masters, table, draining, region-in-transition, table-lock, running, master, namespace, hbaseid, online-snapshot, replication, splitWAL, recovering-regions, rs]

Cheers
On Thu, Oct 10, 2013 at 10:46 AM, Tianying Chang <[EMAIL PROTECTED]> wrote:

> Hi,
>
> I found that there is no master znode under /hbase in zookeeper.
> Actually, the /hbase directory is not even created after just start
> the master (Based on Log and webUI, the master is up fine). After I
> bring up a RS, the /hbase directory and some other znode like
> /hbase/backup-masters,  /hbase/online-snapshot, ... and created, but still no  /hbase/master.
>
>
> Anyone has any idea why? Without /hbase/master znode, RS/client won't
> be able to find the master.
>
> Thanks
> Tian-Ying
>
+
Stack 2013-10-10, 18:09
+
Tianying Chang 2013-10-11, 00:37