Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Pig >> mail # dev >> classpath issues


This issue should get fixed by PIG-2282 as soon as I commit it.

Cheers,
--
Gianmarco

On Tue, Jan 10, 2012 at 01:29, Daniel Dai <[EMAIL PROTECTED]> wrote:

> Oh, that's due to a recent change PIG-2431. We upgrade hadoop but not sync
> eclipse files.
>
> On Mon, Jan 9, 2012 at 4:18 PM, christopher justin <
> [EMAIL PROTECTED]> wrote:
>
> > I have now verified this with two other developers.  There must be
> > something we are missing that isn't documented on
> > https://cwiki.apache.org/confluence/display/PIG/HowToContribute ?   Two
> > of us are on Macs (1 running Apache Ant 1.7.1 and the other Ant 1.8.2)
> and
> > the other is on Linux running Ant 1.8.2 - all of us are on Sun Java 1.6.1
> > .  Doing nothing more than this:
> >
> > svn co http://svn.apache.org/repos/asf/pig/trunk .
> > ant eclipse-files
> >
> > The build succeeds, however the .classpath (and
> > .eclipse.templates/.classpath ) have  JARs that do not match
> > ivy/library.properties.  For example, inside .classpath and
> > .eclipse.templates/.classpath are:
> >
> > <classpathentry exported="true" kind="lib"
> > path="build/ivy/lib/Pig/hadooop-core-0.20.2.jar"/>
> > <classpathentry exported="true" kind="lib"
> > path="build/ivy/lib/Pig/hadooop-test-0.20.2.jar"/>
> > <classpathentry exported="true" kind="lib" path="lib/automaton.jar"/>
> > <classpathentry exported="true" kind="lib"
> > path="build/ivy/lib/Pig/commons-codec-1.3.jar"/>
> > <classpathentry exported="true" kind="lib"
> > path="build/ivy/lib/Pig/guava-r06.jar"/>
> >
> > ivy/library.properties for the respective deps are:
> > automaton.version=1.11-8
> > guava.version=11.0
> > commons-codec.version=1.4
> > hadoop-core.version=0.20.205.0
> > hadoop-test.version=0.20.205.0
> >
> >
> > I have attached the output (ant.log) from running "ant eclipse-files" .
> > Oddly, Ivy resolves the deps but the .classpath isn't reflecting the
> right
> > versions.
> >
> > Thanks for your help .  I apologize in advance if it is something very
> > silly i just didn't read on the wiki.
> >
> >
> > chris
> >
> >
> >
> > On Mon, Jan 9, 2012 at 3:20 PM, Aniket Mokashi <[EMAIL PROTECTED]
> >wrote:
> >
> >> I do ant eclipse-files and it works for me. Am I missing something?
> >>
> >> ~Aniket
> >>
> >> On Mon, Jan 9, 2012 at 12:03 PM, christopher justin <
> >> [EMAIL PROTECTED]> wrote:
> >>
> >> > Good afternoon all.
> >> > I am curious if there already exists a JIRA for what seems a very
> >> obvious
> >> > issue when attempting to build and import into Eclipse have issues.
> >>  When i
> >> > check out trunk and the 0.9 branch and simply build, the classpath
> does
> >> not
> >> > reflect what the versions seen in ivy library.properties.   The output
> >> > shows ivy resolving the right versions but some how those versions do
> >> not
> >> > end up in .classpath .   Of course i can simply hand edit the
> .classpath
> >> > and resolve my issues when importing into Eclipse, but this not ideal.
> >> >
> >> > thanks for your help
> >> >
> >> >
> >> > chris
> >> >
> >>
> >>
> >>
> >> --
> >> "...:::Aniket:::... Quetzalco@tl"
> >>
> >
> >
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB