Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Bigtop >> mail # dev >> supported puppet versions


Copy link to this message
-
Re: supported puppet versions
Hi Andrey!

On Thu, Aug 8, 2013 at 11:14 AM, Andrey Klochkov
<[EMAIL PROTECTED]> wrote:
> Hello,
> What puppet versions are supported by big top currently? I'm using big top
> 0.6, and previously I noticed that it didn't work with puppet 3.x but
> puppet 2.7 worked fine.

Your observation is absolutely correct -- we're stuck with Puppet 2.[67].
Personally I prefer Puppet 2.7 in my daily deploys of Bigtop, but 2.6
should be fine as well.

Puppet 3.x is known to be incompatible.

> Unfortunately, now I have to switch to 3.x because
> of our IT using it to manage the infrastructure. Should it actually work
> with 0.6, trunk? Any Jiras tracking that?

We do have a JIRA tracking refactoring of our Puppet code:
    https://issues.apache.org/jira/browse/BIGTOP-840

My original idea was to do a pretty significant overhaul, but
perhaps I've bitten way more that I was able to chew :-(

We would *love* if you could help us tackle it!

Thanks,
Roman.