Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Avro >> mail # user >> Java MapReduce Avro Jackson Error


+
Deepak Nettem 2012-03-19, 22:48
+
Deepak Nettem 2012-03-19, 23:20
+
Tatu Saloranta 2012-03-19, 23:27
+
Deepak Nettem 2012-03-20, 00:05
+
Deepak Nettem 2012-03-20, 00:06
Copy link to this message
-
Re: Java MapReduce Avro Jackson Error
What version of Avro are you using?

You may want to try Avro 1.6.3 + Jackson 1.8.8.

This is related, but is not your exact problem.
https://issues.apache.org/jira/browse/AVRO-1037
 
You are likely pulling in some other version of jackson somehow.  You may
want to use 'mvn dependency:tree' on your project to see where all the
dependencies are coming from.  That may help identify the culprit.

-Scott

On 3/19/12 5:06 PM, "Deepak Nettem" <[EMAIL PROTECTED]> wrote:
>Sorry,
>
>I meant, I added the jackson-core-asl dependency, and still get the error.
>
>    <groupId>org.codehaus.jackson</groupId>
>      <artifactId>jackson-core-asl</artifactId>
>      <version>1.5.2</version>
>      <scope>compile</scope>
>    </dependency>
>
>
>On Mon, Mar 19, 2012 at 8:05 PM, Deepak Nettem <[EMAIL PROTECTED]>
>wrote:
>
>Hi Tatu,
>
>I added the dependency:
>
><dependency>    
>    <groupId>org.codehaus.jackson</groupId>
>      <artifactId>jackson-mapper-asl</artifactId>
>      <version>1.5.2</version>
>      <scope>compile</scope>
>    </dependency>
>
>
>But that still gives me this error:
>
>Error:
>org.codehaus.jackson.JsonFactory.enable(Lorg/codehaus/jackson/JsonParser$F
>eature;)Lorg/codehaus/jackson/JsonFactory;
>
>Any other ideas?
>
>
>On Mon, Mar 19, 2012 at 7:27 PM, Tatu Saloranta <[EMAIL PROTECTED]>
>wrote:
>
>On Mon, Mar 19, 2012 at 4:20 PM, Deepak Nettem <[EMAIL PROTECTED]>
>wrote:
>> I found that the Hadoop lib directory contains
>>jackson-core-asl-1.0.1.jar
>> and jackson-mapper-asl-1.0.1.jar.
>>
>> I removed these, but got this error:
>> hadoop Exception in thread "main" java.lang.NoClassDefFoundError:
>> org/codehaus/jackson/map/JsonMappingException
>>
>> I am using Maven as a build tool, and my pom.xml has this dependency:
>>
>>     <dependency>
>>     <groupId>org.codehaus.jackson</groupId>
>>       <artifactId>jackson-mapper-asl</artifactId>
>>       <version>1.5.2</version>
>>       <scope>compile</scope>
>>     </dependency>
>>
>> Any help would on this issue would be greatly appreciated.
>
>
>You may want to add similar entry for jackson-core-asl -- mapper does
>require core, and although there is transient dependency from mapper,
>Maven does not necessarily enforce correct version.
>So it is best to add explicit dependency so that version of core is
>also 1.5.x; you may otherwise just get 1.0.1 of that one.
>
>-+ Tatu +-
>
>
>
>
>
>
>
>
+
Tatu Saloranta 2012-03-20, 01:12
+
Deepak Nettem 2012-03-20, 01:23
+
Tatu Saloranta 2012-03-20, 01:34
+
Something Something 2012-03-20, 01:43
+
Scott Carey 2012-03-20, 03:25
+
Deepak Nettem 2012-03-27, 02:58
+
Scott Carey 2012-03-27, 03:25
+
Deepak Nettem 2012-03-29, 14:28
+
Ken Krugler 2012-03-20, 02:51
+
Deepak Nettem 2012-03-20, 03:04