Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - Problems using unqualified hostname on hbase


Copy link to this message
-
Re: Problems using unqualified hostname on hbase
yun peng 2012-10-18, 02:09
Thanks for the notes. I am running the project configuration for
comparison, (as worst case for locality)...
On other hand, even if I make them to colocate, the problem persists, as
the property hbase.zookeeper.quorum has to be fully qualified name..

Does this problem have anything to do with DNS setting in hbase?
Regards,
Richard

On Wed, Oct 17, 2012 at 3:13 PM, Doug Meil <[EMAIL PROTECTED]>wrote:

>
> Hi there.  You generally don't want to run with 2 clusters like (HBase on
> one, HDFS on the other) that because your regions have 0% locality.
>
> For more information on this topic, seeĊ .
>
> http://hbase.apache.org/book.html#regions.arch.locality
>
>
>
>
> On 10/17/12 12:19 PM, "Richard Tang" <[EMAIL PROTECTED]> wrote:
>
> >Hello, everyone,
> >I have problems using hbase based on unqualified hostname. My ``hbase``
> >runs  in a cluster and ``hdfs`` on another cluster. While using fully
> >qualified name on ``hbase``, for properties like ``hbase.rootdir`` and
> >``hbase.zookeeper.quorum``, there is no problem. But when I change them to
> >be shorter unqualified names, like ``node4`` and ``node2``, (which are
> >resolved to local ip address by ``/etc/hosts``, like ``10.0.0.8``), the
> >hbase cluster begin to throw ``Connect refused`` messages. Anyone
> >encounter
> >same problem here?What is the possible reason behind all theses? Thanks.
> >Regards,
> >Richard
>
>
>