Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # user >> How to run HBase tests against 0.94? (seems to be for and old version of HBase)


+
Jean-Marc Spaggiari 2013-01-02, 15:10
+
Ted Yu 2013-01-02, 15:30
Copy link to this message
-
Re: How to run HBase tests against 0.94? (seems to be for and old version of HBase)
Exact, I'm running the test for 7467 ;)

I was trying to avoid to run ALL the tests to save some time. I have
started them now. using dev-support/hbasetest.sh runAllTests

I will submit the patch as soon as I get a successful test.

I did the initial build/install using maven clean install -DskipTests.

I got the error when I tried to run the test using Eclipse. I will
take a look into hbasetest.sh to see if the magic is inside ;)

JM

2013/1/2, Ted Yu <[EMAIL PROTECTED]>:
> I guess you're testing your patch for HBASE-7467.
>
> You can use the tip of 0.94 codebase plus your patch.
> The following command should run all test cases:
>
> mvn clean test -P runAllTests > result.txt &
>
> Cheers
>
> On Wed, Jan 2, 2013 at 7:10 AM, Jean-Marc Spaggiari
> <[EMAIL PROTECTED]
>> wrote:
>
>> Hi,
>>
>> When I try to run the tests on 0.94.4RC I'm getting "hbase-default.xml
>> file seems to be for and old version of HBase (@@@VERSION@@@), this
>> version is 0.94.4"
>>
>> It seems I need to setup hbase.defaults.for.version.skip to true, but
>> on the test, the configuration is created even before we can access a
>> Before class. So it's failing right from the initialization.
>>
>> What's the right way to run the tests under 0.94.4RC? How can I skip this
>> test?
>>
>> Thanks,
>>
>> JM
>>
>
+
Vandana Ayyalasomayajula 2013-01-02, 16:24
+
Jean-Marc Spaggiari 2013-01-02, 17:03
+
Andrew Purtell 2013-01-02, 17:19
+
Nicolas Liochon 2013-01-02, 17:15
+
Nicolas Liochon 2013-01-02, 15:59
+
Nicolas Liochon 2013-01-02, 15:22