Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> Help on running HBase on Windows 7 Ultimate x64


Copy link to this message
-
Re: Help on running HBase on Windows 7 Ultimate x64
Maybe the shell is dumb on windows Rob?

If you write a bit of java, does that work fine as a client?  See
http://hbase.apache.org/docs/r0.20.6/api/org/apache/hadoop/hbase/client/package-summary.html#package_description
for a bit of code to try (check it for any linux presumptions first
(smile)).

You saw this doc. too I suppose?
http://hbase.apache.org/docs/r0.20.6/cygwin.html

St.Ack
On Fri, Jul 30, 2010 at 1:49 PM, Rob Marano <[EMAIL PROTECTED]> wrote:
> Hey Guys,
>
> I am having a whopper of a major problem getting HBase v0.20.5 running on my
> system, which is a Windows 7 x64 Ultimate running with 64-bit Java
> v1.6.0_20, Hadoop v0.20.2, and Zookeeper v3.3.1.
>
> Hadoop runs well.  Zookeeper runs well.  HBase seems to run well, but when I
> issue the hbase shell command and run Hbase command status or help or
> anything else, it hangs.  I got the same configuration to run well on my
> Ubuntu Server 10.04 x64.
>
> Has anyone gotten HBase to run on Windows?  I am trying to prototype my
> upcoming new version of software to be based upon Hadoop, HBase and
> Zookeeper.
>
> So basically I am crying uncle and asking for some serious help!
>
> Tia,
> Rob
> --
> Arnold H. Glasow - "Success is simple. Do what's right, the right way, at
> the right time."
>