Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase, mail # user - snapshot export failure


+
Cooper Bethea 2013-10-29, 22:06
+
Ted Yu 2013-10-29, 22:09
+
Cooper Bethea 2013-10-29, 22:29
Copy link to this message
-
Re: snapshot export failure
Matteo Bertozzi 2013-10-29, 22:35
could you re-run the ExportSnapshot and post the output?
also could you check the exit code? echo $?
Matteo

On Tue, Oct 29, 2013 at 10:29 PM, Cooper Bethea <[EMAIL PROTECTED]>wrote:

> Ted, thanks for responding.
>
> I've checked the namenode log. There are no messages at greater than INFO
> level emitted by the namenode during the period when the copy ran.
>
> The Export job tasks likewise emitted no errors.
>
>
> On Tue, Oct 29, 2013 at 3:09 PM, Ted Yu <[EMAIL PROTECTED]> wrote:
>
> > bq. There are no errors in the logs.
> >
> > I assume you have checked master log / region server logs.
> > How about namenode log ?
> >
> >
> > On Tue, Oct 29, 2013 at 3:06 PM, Cooper Bethea <[EMAIL PROTECTED]
> > >wrote:
> >
> > > Hi everybody,
> > >
> > > I've been attempting to export a snapshot from one of my HBase clusters
> > to
> > > the other. Both clusters are running 0.94.6-cdh4.4.0. I am able to
> > > successfully export a very small collection (few MB), but when I
> attempt
> > to
> > > export a larger collection something odd happens. The Export MR
> finishes
> > > successfully, but leaves files in /hbase/.snapshot/.tmp/SNAPSHOT_NAME
> > > instead of /hbase/.snapshot/SNAPSHOT_NAME. There are no errors in the
> > logs.
> > >
> > > Is this familiar to anyone?
> > >
> >
>
+
Cooper Bethea 2013-10-29, 23:09