Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Flume >> mail # dev >> Thrift Source


Copy link to this message
-
Re: Thrift Source
I think I initially put 0.9 as the dependency, but Hbase 0.92 has a 0.7.0 dependency, so if there is an app that uses Flume SDK and HBase client they would hit ClassNotFoundExceptions etc because of incompatibilities. I submitted a patch upstream (though it is not yet in), that uses a better Thrift server, which was introduced in 0.8.

Cheers,
Hari
On Wednesday, June 5, 2013 at 6:48 PM, Stefan Krawczyk wrote:

> Hi All,
>
> I was trying to test out the Thrift source that on the 1.4.0 branch, but I
> see that the dependency on Thrift is 0.7.0. Are there any plans to upgrade
> this to 0.8.0 or 0.9.0 ?
>
> Cheers,
>
> Stefan