Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Sqoop >> mail # user >> Sqoop 1.99.2 + Cloud Era Hadoop 200 error


+
Madhanmohan Savadamuthu 2013-07-02, 17:05
+
Mengwei Ding 2013-07-02, 17:20
+
Madhanmohan Savadamuthu 2013-07-03, 04:19
+
Mengwei Ding 2013-07-03, 14:00
+
Madhanmohan Savadamuthu 2013-07-03, 16:18
+
Mengwei Ding 2013-07-03, 17:35
+
Madhanmohan Savadamuthu 2013-07-04, 08:15
+
Mengwei Ding 2013-07-04, 17:38
+
Madhanmohan Savadamuthu 2013-07-05, 18:42
Copy link to this message
-
Re: Sqoop 1.99.2 + Cloud Era Hadoop 200 error
Hi Madhan,

It's really great to hear that the problem is clear. Enjoy Sqoop2. If you
have further question, I will be more than happy to answer.

Have a nice day!

Best,
Mengwei
On Fri, Jul 5, 2013 at 11:42 AM, Madhanmohan Savadamuthu <[EMAIL PROTECTED]
> wrote:

> Mengwei,
>
> Issue is solved. MapReduce configuration file had invalid configuration
> and was creating problem.
>
> *File Name:* /etc/hadoop/conf/mapred-site.xml
> *Parameter Name:* mapred.job.tracker
> *Original Value: *neededForHive:999999
> *Modified Value: *<machinename>:9001
>
> After this change, this are working fine now. Note that I have followed
> suggestions provided by Mengwei in this thread.
>
> Regards,
> Madhan
>
> On Thu, Jul 4, 2013 at 11:08 PM, Mengwei Ding <[EMAIL PROTECTED]>wrote:
>
>> Ok, Madhan, why not.
>>
>> Could you kindly provide you availabilities of time and communication
>> tools. I will be more than happy to help you out with this.
>>
>> Best,
>> Mengwei
>>
>>
>> On Thu, Jul 4, 2013 at 1:15 AM, Madhanmohan Savadamuthu <
>> [EMAIL PROTECTED]> wrote:
>>
>>> After doing changes in catalina.properties also, same issue is coming.
>>>
>>> is there any possibility for interactive discussion on this issue?
>>>
>>> Regards,
>>> Madhan
>>>
>>>  On Wed, Jul 3, 2013 at 11:05 PM, Mengwei Ding <
>>> [EMAIL PROTECTED]> wrote:
>>>
>>>> Thank you for your prompt response, sir. Please don't worry, I can help
>>>> you out with this until your problem is done.
>>>>
>>>> Well, let's try out our new method of adding dependency jar files, and
>>>> forget about the addtowar.sh script.
>>>>
>>>> Please following these instructions:
>>>>
>>>>  "
>>>> Installing Dependencies
>>>>
>>>> Hadoop libraries must be available on node where you are planning to
>>>> run Sqoop server with proper configuration for major services - NameNode
>>>> and either JobTracker or ResourceManager depending whether you are running
>>>> Hadoop 1 or 2. There is no need to run any Hadoop service on the same node
>>>> as Sqoop server, just the libraries and configuration must be available.
>>>>
>>>> Path to Hadoop libraries is stored in file catalina.properties inside
>>>> directory server/conf. You need to change property called common.loader to
>>>> contain all directories with your Hadoop libraries. The default expected
>>>> locations are /usr/lib/hadoop and /usr/lib/hadoop/lib/. Please check out
>>>> the comments in the file for further description how to configure different
>>>> locations.
>>>>
>>>> Lastly you might need to install JDBC drivers that are not bundled with
>>>> Sqoop because of incompatible licenses. You can add any arbitrary Java jar
>>>> file to Sqoop server by copying it into lib/ directory. You can create this
>>>> directory if it do not exists already.
>>>> "
>>>>
>>>> I can give you my configuration as an example. So in my
>>>> catalina.properties file, I have the following line:
>>>>
>>>> *
>>>> common.loader=${catalina.base}/lib,${catalina.base}/lib/*.jar,${catalina.home}/lib,${catalina.home}/lib/*.jar,${catalina.home}/../lib/*.jar,/usr/lib/hadoop/client-0.20/*.jar,/home/mengweid/Downloads/mysql-connector-java-5.1.25-bin.jar
>>>> *
>>>>
>>>> The */usr/lib/hadoop/client-0.20/*.jar *is used to include all
>>>> hadoop-related jars, and *mysql-connector-java-5.1.25-bin.jar *is used
>>>> for JDBC driver.
>>>>
>>>> Please try this, and let me know whether it works. Thank you.
>>>>
>>>> Best,
>>>> Mengwei
>>>>
>>>>
>>>> On Wed, Jul 3, 2013 at 9:18 AM, Madhanmohan Savadamuthu <
>>>> [EMAIL PROTECTED]> wrote:
>>>>
>>>>> I did deployment as sugggested in below thread. I am not able to
>>>>> successfully use sqoop2. I am attaching the services log for your
>>>>> references.
>>>>>
>>>>> I made sure that exact same set of JAR files in appropriate location
>>>>> and also deleted sqoop folder before starting the sqoop server.
>>>>>
>>>>> *Error Message:*
>>>>>  Exception has occurred during processing command
>>>>> Exception: com.sun.jersey.api.client.UniformInterfaceException
+
Madhanmohan Savadamuthu 2013-07-09, 13:56
+
Jarek Jarcec Cecho 2013-07-09, 15:16
+
Madhanmohan Savadamuthu 2013-07-09, 15:54
+
Mengwei Ding 2013-07-12, 00:53
+
Madhanmohan Savadamuthu 2013-07-16, 17:13
+
Jarek Jarcec Cecho 2013-07-16, 17:51
+
Abraham Elmahrek 2013-07-02, 17:23