Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo >> mail # dev >> MiniAccumuloCluster in Servlet


+
Miguel Pereira 2013-10-26, 15:27
+
Billie Rinaldi 2013-10-26, 15:35
+
Miguel Pereira 2013-10-26, 16:08
+
Josh Elser 2013-10-26, 16:14
+
Miguel Pereira 2013-10-26, 16:46
+
Miguel Pereira 2013-10-26, 17:01
Copy link to this message
-
Re: MiniAccumuloCluster in Servlet
I think that's probably correct. In master, we have a better way of
setting MAC's classpath than setting the classpath system property.
You can set the classpaths explicitly in the MAConfig.

--
Christopher L Tubbs II
http://gravatar.com/ctubbsii
On Sat, Oct 26, 2013 at 1:01 PM, Miguel Pereira
<[EMAIL PROTECTED]> wrote:
> Or maybe Tomcat is overwriting the system class path an so MAC can't see
> the jars?
>
>
> On Sat, Oct 26, 2013 at 12:46 PM, Miguel Pereira
> <[EMAIL PROTECTED]>wrote:
>
>> The MiniAccumuloCluster logs only display this one line:
>>
>>
>> Error: Could not find or load main class org.apache.accumulo.start.Main
>>
>> That's it :/ Which leads me to believe there is something wrong with my
>> tomcat configuration?
>>
>>
>>
>> On Sat, Oct 26, 2013 at 12:14 PM, Josh Elser <[EMAIL PROTECTED]> wrote:
>>
>>> Miguel,
>>>
>>> Check the logs directory underneath the directory you provided to
>>> MiniAccumuloCluster.
>>>
>>> Check the non-empty files. You'll likely find something there that tells
>>> you what's up.
>>>
>>> On 10/26/2013 12:08 PM, Miguel Pereira wrote:
>>>
>>>> Sorry, I intended to type accumulo-*start*-1.5.0.jar
>>>>
>>>> And accumulo-server-1.5.0.jar is also there.
>>>>
>>>>
>>>> On Sat, Oct 26, 2013 at 11:35 AM, Billie Rinaldi
>>>> <[EMAIL PROTECTED]>**wrote:
>>>>
>>>>  MAC depends on accumulo-start and accumulo-server as well.
>>>>>
>>>>> Billie
>>>>> On Oct 26, 2013 11:28 AM, "Miguel Pereira" <[EMAIL PROTECTED]>
>>>>> wrote:
>>>>>
>>>>>  Hia guys i've been stuck on this one for a while so any help is
>>>>>> appreciated..
>>>>>>
>>>>>> Code works as a normal java application but when I deploy it and try to
>>>>>> hook into a ServletContextListener to start up a MiniAccumuloCluster
>>>>>> I get this error in the Tomcat 7 logs:
>>>>>>
>>>>>> SEVERE: Error listenerStart
>>>>>> Oct 26, 2013 10:55:18 AM org.apache.catalina.core.**StandardContext
>>>>>> startInternal
>>>>>> SEVERE: Context [<myapp name>] startup failed due to previous errors
>>>>>>
>>>>>> .....
>>>>>>
>>>>>> INFO: Deploying web application archive
>>>>>> /usr/local/apache-tomcat-7.0.**42/<myapp name>
>>>>>> INITIALIZING SERVLET CONTEXT
>>>>>> Oct 26, 2013 10:55:18 AM org.apache.catalina.core.**StandardContext
>>>>>> listenerStart
>>>>>> SEVERE: Exception sending context initialized event to listener
>>>>>> instance
>>>>>>
>>>>> of
>>>>>
>>>>>> class web.servlet.**MyServletContextListener
>>>>>> java.lang.RuntimeException: Initialize process returned 1
>>>>>>      at
>>>>>>
>>>>>>
>>>>>>  org.apache.accumulo.**minicluster.**MiniAccumuloCluster.start(**
>>>>> MiniAccumuloCluster.java:304)
>>>>>
>>>>>>      at
>>>>>>
>>>>>>
>>>>>>  web.servlet.**MyServletContextListener.**contextInitialized(**
>>>>> MyServletContextListener.java:**74)
>>>>>
>>>>>>      at
>>>>>>
>>>>>>
>>>>>>  org.apache.catalina.core.**StandardContext.listenerStart(**
>>>>> StandardContext.java:4939)
>>>>>
>>>>>>
>>>>>> The MiniAccumuloCluster logs ( Initialize and Main ) display this
>>>>>> error:
>>>>>>
>>>>>> Error: Could not find or load main class org.apache.accumulo.start.Main
>>>>>>
>>>>>> However accumulo-core-1.5.0.jar is present in the WEB-INF/lib directory
>>>>>>
>>>>> of
>>>>>
>>>>>> the exploded war...
>>>>>>
>>>>>> Thoughs? and thanks in advance,
>>>>>> Miguel
>>>>>>
>>>>>>
>>>>>
>>>>
>>
+
Miguel Pereira 2013-10-26, 20:57