Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - hbase error


Copy link to this message
-
Re: hbase error
Jean-Marc Spaggiari 2012-11-21, 17:25
Also, you might want to run bin/hbase hbck to make sure everything is fine.

JM

2012/11/21, anil gupta <[EMAIL PROTECTED]>:
> Hi Wanli,
>
> Somehow, Your ".META." table is having problem. Read more about meta table
> here: http://hbase.apache.org/book/arch.catalog.html
>
> Try to do a restart and and see whether it works or not. If not, then look
> into the logs of HBase start-up and see if their is any problem reported in
> logs.
>
> HTH,
> Anil
>
>
> On Wed, Nov 21, 2012 at 8:32 AM, wanli gao <[EMAIL PROTECTED]> wrote:
>
>> hi all,
>> i m now running hbase on pseudo-distributed mode, and when i open hbase
>> webUI: http://localhost:60010/master.jsp,its give an error:
>> Trying to contact region server null for region , row '', but failed
>> after 3 attempts.
>> Exceptions:
>> org.apache.hadoop.hbase.TableNotFoundException: .META.
>> org.apache.hadoop.hbase.TableNotFoundException: .META.
>> org.apache.hadoop.hbase.TableNotFoundException: .META.
>> and when i run list on hbase it give the same error,
>> my hbase-site.xml is :
>>
>> <configuration>
>> <property>
>> <name>hbase.rootdir</name>
>> <value>hdfs://localhost:9000/hbase</value>
>> </property>
>> <property>
>> <name>hbase.cluster.distributed</name>
>> <value>true</value>
>> </property>
>> <property>
>> <name>hbase.zookeeper.property.clientPort</name>
>> <value>5000</value>
>> <description>Property from ZooKeeper's config zoo.cfg.
>> The port at which the clients will connect.
>> </description>
>> </property>
>> <property>
>> <name>hbase.zookeeper.quorum</name>
>> <value>localhost</value>
>> </property>
>> <property>
>> <name>hbase.tmp.dir</name>
>> <value>/home/wanli/hadoop/hbasetmp</value>
>> <description>Temporary directory on the local filesystem.</description>
>> </property>
>> <property>
>> <name>hbase.zookeeper.property.dataDir</name>
>> <value>home/wanli/hadoop/hbasezook</value>
>> </property>
>> <property>
>> <name>hbase.zookeeper.property.clientPort</name>
>> <value>6500</value>
>> <description>Property from ZooKeeper config zoo.cfg.</description>
>> </property>
>> </configuration>
>>
>> is there anyone know this error,
>> thanks
>>
>> sorry
>> i don`t know is it successful that i post,so i post again
>>
>
>
>
> --
> Thanks & Regards,
> Anil Gupta
>