Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> zookeeper connection problem in pseudo mode


Copy link to this message
-
Re: zookeeper connection problem in pseudo mode
this is how I stop the firewall. https://help.ubuntu.com/community/IptablesHowTo

sudo nano -w /root/fw.stop

echo "Stopping firewall and allowing everyone..."
iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT

sudo /root/fw.stop

at last I saw the output:
huyong@huyong-laptop:~/hbase-0.90.3/bin$ sudo /root/fw.stop
stopping firewall

I am not sure weather it is what you mean to close the firewall. I
don't know if my Hadoop version 0.20.2 and Hbase 0.90.3 version are
compatible.
Yong
On Thu, Jan 5, 2012 at 6:32 PM, Royston Sellman
<[EMAIL PROTECTED]> wrote:
> Just to check - did you disable it the way Tom suggested? By stopping iptables?
> It's not sufficient just to turn off firewall from the control panel/app.
>
> Best,
> Royston
>
>
> On 5 Jan 2012, at 17:00, yonghu wrote:
>
>> I have already disabled ipv6 and close the firewall, but I still get
>> the same problem. :(
>>
>> Yong
>>
>> On Thu, Jan 5, 2012 at 5:16 PM, yonghu <[EMAIL PROTECTED]> wrote:
>>> I set up a pseudo mode, it also needs to close the firewall?
>>>
>>> Yong
>>>
>>> On Thu, Jan 5, 2012 at 4:59 PM, Tom Wilcox <[EMAIL PROTECTED]> wrote:
>>>> I've seen that error before. Have you tried turning off your firewalls on each node?
>>>>
>>>> I do it like this:
>>>>
>>>> cat $HADOOP_INSTALL/conf/slaves | xargs -I{} ssh root@{} '/etc/init.d/iptables stop'
>>>> ssh root@jobtracker '/etc/init.d/iptables stop'
>>>> ssh root@namenode '/etc/init.d/iptables stop'
>>>>
>>>> Worth a crack if you haven't tried it yet.
>>>> ________________________________________
>>>> From: Leonardo Gamas [[EMAIL PROTECTED]]
>>>> Sent: 05 January 2012 15:45
>>>> To: [EMAIL PROTECTED]
>>>> Subject: Re: zookeeper connection problem in pseudo mode
>>>>
>>>> I had a similar problem some time ago. The problem seems to be in the ipv6
>>>> configuration. I solved it disabling ipv6 on my host editing /etc/hosts.
>>>>
>>>> 2012/1/5 yonghu <[EMAIL PROTECTED]>
>>>>
>>>>> Hallo,
>>>>>
>>>>> I tried the pseudo distribution mode of HBase. The Hadoop version is
>>>>> 0.20.2. I configured the hbase-site.xml as
>>>>>
>>>>> <configuration>
>>>>>  <property>
>>>>>    <name>hbase.rootdir</name>
>>>>>    <value>hdfs://localhost:9000/hbase</value>
>>>>>  </property>
>>>>>  <property>
>>>>>    <name>dfs.replication</name>
>>>>>    <value>1</value>
>>>>>  </property>
>>>>> </configuration>
>>>>>
>>>>> as same as in core-site.xml and hdfs-site.xml files of Hadoop, separately.
>>>>>
>>>>> I can successfully start HBase. But when I tried to create a table, I
>>>>> got following error information:
>>>>> ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is
>>>>> able to connect to ZooKeeper but the connection closes immediately.
>>>>> This could be a sign that the server has too many connections (30 is
>>>>> the default). Consider inspecting your ZK server logs for that error
>>>>> and then make sure you are reusing HBaseConfiguration as often as you
>>>>> can. See HTable's javadoc for more information.
>>>>>
>>>>> And I checked my ZK log and found:
>>>>>
>>>>> 2012-01-05 15:59:02,909 INFO org.apache.zookeeper.ClientCnxn: Opening
>>>>> socket connection to server localhost/0:0:0:0:0:0:0:1:2181
>>>>> 2012-01-05 15:59:02,909 WARN org.apache.zookeeper.ClientCnxn: Session
>>>>> 0x134ae4d4a6d0001 for server null, unexpected error, closing socket
>>>>> connection and attempting reconnect
>>>>> java.net.ConnectException: Connection refused
>>>>>        at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>>>>>        at
>>>>> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
>>>>>        at
>>>>> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1119)
>>>>>
>>>>> This error information appeared repeatly. Can anyone tell how to solve
>>>>> this problem?
>>>>>
>>>>> Thanks!
>>>>>
>>>>> Yong
>>>>>
>>>>
>