Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop >> mail # general >> Java Versions and Hadoop


Copy link to this message
-
Re: Java Versions and Hadoop
On 10/10/11 22:32, [EMAIL PROTECTED] wrote:
>
>> I believe you mean when will it be compatible with Java 7, not require it
>> (based on all you mention above, other than the word 'required').  Is that
>> the case?
>
> I meant, "when will I be able to use some of the JDK 7 APIs in Hadoop code
> ?", which means JDK7 is required for Hadoop.
>

There are enough language changes in Java7 to make considering this
worthwhile; the Java5->Java6 changes were so minor (@Override on
interface) that it wasn't that compelling.

I would suggest moving up projects on the side first, layers on top,
like your MPI-on-YARN stuff, where there is little or no installed base
to worry about