Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> problem running two consecutive MiniAccumuloClusters


Copy link to this message
-
Re: problem running two consecutive MiniAccumuloClusters
On Fri, Jan 11, 2013 at 9:26 AM, Keith Turner <[EMAIL PROTECTED]> wrote:

> On Thu, Jan 10, 2013 at 6:33 PM, Billie Rinaldi
> <[EMAIL PROTECTED]> wrote:
> > I'm experimenting with converting all of our MapReduce tests over to use
> > MiniAccumuloCluster.  It's been really challenging to write tests that
> > correctly test the behavior of our input and output formats (asserts
> within
> > a Mapper don't work as one would hope), but I've gotten all of the test
> > classes to pass individually.  However, when I run any two of them, the
> > second one fails with the message: FATAL util.Initialize: Zookeeper needs
> > to be up and running in order to init. Exiting ...
> >
> > I can replicate the issue by copying the existing MiniAccumuloClusterTest
> > to a different name (still ending in Test) and running them both.
> >
> > Any thoughts?
>
> I will look into it.
>
> Are you running two instances of MiniAccumuloClusterTest from the same
> java process or from different Java processes?
>

I'm running them by executing a "mvn clean package" at the command line.
They also fail if you select both and run as junit test in eclipse, but
it's slightly different -- the test just seems to hang at the end of the
first test though you see the same FATAL message.  At the command line,
it's clear that it fails at the beginning of the second test.

Billie
>
> >
> > Billie
>