Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo, mail # dev - VFS class reloading?


Copy link to this message
-
Re: VFS class reloading?
John Vines 2013-04-17, 14:15
The issue wasn't that it wasn't picking up jars in there, it wasn't
dynamically loading them. I'll test again for sanity's sake.
On Tue, Apr 16, 2013 at 8:57 PM, <[EMAIL PROTECTED]> wrote:

> I was able to confirm that 'accumulo classpath' picked up jars in lib/ext.
> So it's configured to know about that location.
>
> ----- Original Message -----
> From: "Eric Newton" <[EMAIL PROTECTED]>
> To: [EMAIL PROTECTED]
> Sent: Tuesday, April 16, 2013 7:52:09 PM
> Subject: Re: VFS class reloading?
>
> We have tests for dynamic loading of classes so I'm pretty sure it works.
>
> John, can you repeat the failure?
>
> -Eric
>
>
>
> On Tue, Apr 16, 2013 at 6:50 PM, Dave Marion <[EMAIL PROTECTED]> wrote:
>
> > Looking at the code, it should work. Keith and I had several
> conversations
> > about what the new classloader should do. I believe that he wanted it to
> > behave like the old one and what I see in the code supports that. If it
> is
> > not working, then I would say create a ticket for it for now. I'll try to
> > replicate it tonight if I have time.
> >
> > -----Original Message-----
> > From: Dave Marion [mailto:[EMAIL PROTECTED]]
> > Sent: Tuesday, April 16, 2013 6:41 PM
> > To: [EMAIL PROTECTED]
> > Subject: RE: VFS class reloading?
> >
> > The implementation changed several times, so the pre-1.5 layout may not
> > work. In 1.5, using the bootstrap script, it should put the accumulo jars
> > into HDFS and dynamic loading from there should occur. I'll try and test
> > tonight if I have time.
> >
> > -----Original Message-----
> > From: John Vines [mailto:[EMAIL PROTECTED]]
> > Sent: Tuesday, April 16, 2013 6:30 PM
> > To: Accumulo Dev List
> > Subject: VFS class reloading?
> >
> > Maybe I missed something with the switch to the VFS classloader, but does
> > dynamic loading out of lib/ext no longer work? I had accumulo 1.5
> running,
> > threw an iterator in there, but had to restart tserver to get the new
> > iterator picked up. Was that an intentional change?
> >
> >
>