Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> Review Request 23413: ACCUMULO-2988 Upgrade from 1.4 direct to 1.6


Copy link to this message
-
Re: Review Request 23413: ACCUMULO-2988 Upgrade from 1.4 direct to 1.6

This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23413/#review47681
Thanks for doing this! Would be great to see this get in for 1.6.1. Pushing ACCUMULO-2145 might make it easier to test this.
server/base/src/main/java/org/apache/accumulo/server/Accumulo.java
<https://reviews.apache.org/r/23413/#comment83816>

    I'd think this method could just be dropped in favor of the new one. Is there any reason we'd still call this?

server/base/src/main/java/org/apache/accumulo/server/Accumulo.java
<https://reviews.apache.org/r/23413/#comment83817>

    This is kind of an important check. Perhaps move this to a method like "boolean canUpgradeFromDataVersion(int version);" with a comment?

server/base/src/main/java/org/apache/accumulo/server/ServerConstants.java
<https://reviews.apache.org/r/23413/#comment83818>

    We have many different kinds of versions. Please clarify the constant (something like "TWO_DATA_VERSIONS_AGO"), so it's not misused.

server/master/src/main/java/org/apache/accumulo/master/Master.java
<https://reviews.apache.org/r/23413/#comment83819>

    prefer putting this check into a method (canUpgrade? needsUpgrade?... whatever is most appropriate)

server/master/src/main/java/org/apache/accumulo/master/Master.java
<https://reviews.apache.org/r/23413/#comment83820>

    should be in a descriptive function (see previous comments)

server/master/src/main/java/org/apache/accumulo/master/Master.java
<https://reviews.apache.org/r/23413/#comment83821>

    Avoid the string "!METADATA". Log messages should refer to a generic "metadata table" or similar, to be consistent with previous changes, which purged specific table names from being referenced (especially when it's a string literal instead of a constant). This is for future-proofing any other metadata changes we might make later.
- Christopher Tubbs
On July 11, 2014, 3:19 p.m., Sean Busbey wrote: