Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo >> mail # user >> Apach Accumulo Issue


+
navindran.sgk@... 2013-07-09, 08:05
+
Josh Elser 2013-07-09, 10:42
+
Christopher 2013-07-09, 16:50
+
navindran.sgk@... 2013-07-10, 15:35
+
Ott, Charles H. 2013-07-10, 19:39
+
navindran.sgk@... 2013-07-13, 15:55
+
John Vines 2013-07-13, 17:53
+
navindran.sgk@... 2013-07-15, 15:15
+
John Vines 2013-07-15, 16:00
+
navindran.sgk@... 2013-07-16, 15:33
+
John Vines 2013-07-16, 15:41
+
navindran.sgk@... 2013-07-17, 03:56
Copy link to this message
-
Re: Apach Accumulo Issue
Hi John,

Pls find the logs attached for initialing and starting accumulo. Pls do help me in setting up accumulo.

Thanks and Regards,
Navindran Gowrikumar

BSC-1, Next-Level 5th Floor, West Wing
34, IT Highway
PolarisFT-Navallur-Chennai
-----John Vines <[EMAIL PROTECTED]> wrote: -----
To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
From: John Vines <[EMAIL PROTECTED]>
Date: 07/16/2013 09:12PM
Subject: Re: Apach Accumulo Issue
You're providing a lot of partial information all over the place which is making this difficult to debug. Lets start from the beginning.
1. Do you have zookeeper running? (please validate by telnetting the server and sending "ruok". You should receive "imok" before it closes the channel)
2. Do you have hdfs running? (please validate by attempting to write a file to hdfs via hadoop -put and hadoop -cat).
3. Run initialize and please share all of the output you get through the process.
4. If the initialize does go well, please attempt to start accumulo. If it does not success, please check the monitor page on port 50095 and see if it's reporting any recent events. If the monitor is not running, check the monitor*debug.log, master*debug.log, and tserver*debug.log and look for any ERRORs being reported and/or stack traces showing up and share those.
John

On Tue, Jul 16, 2013 at 11:33 AM, <[EMAIL PROTECTED]> wrote:

Hi,

I get the following error when initializing accumulo,

16 08:32:32,569 [hdfs.DFSClient] DEBUG: LeaseChecker@DFSClient[clientName=DFSClient_36687922, ugi=training]: java.lang.Throwable: for testing
        at org.apache.hadoop.hdfs.DFSClient$LeaseChecker.toString(DFSClient.java:1181)
        at java.lang.String.valueOf(String.java:2826)
        at java.lang.StringBuilder.append(StringBuilder.java:115)
        at org.apache.hadoop.hdfs.DFSClient$LeaseChecker.run(DFSClient.java:1170)
        at java.lang.Thread.run(Thread.java:662)
 is interrupted.
java.lang.InterruptedException: sleep interrupted
        at java.lang.Thread.sleep(Native Method)
        at org.apache.hadoop.hdfs.DFSClient$LeaseChecker.run(DFSClient.java:1167)
        at java.lang.Thread.run(Thread.java:662)
Thanks and Regards,
Navindran Gowrikumar

BSC-1, Next-Level 5th Floor, West Wing
34, IT Highway
PolarisFT-Navallur-Chennai
-----John Vines <[EMAIL PROTECTED]> wrote: -----
To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
From: John Vines <[EMAIL PROTECTED]>

Date: 07/15/2013 09:30PM

Subject: Re: Apach Accumulo Issue
It looks like you initialized Accumulo as a different user than what you're trying ot run it as. Either delete /accumulo out of hdfs and reinit as the user you're running it as, or recursively chown /accumulo to the user you're attempting to use.

On Mon, Jul 15, 2013 at 11:15 AM, <[EMAIL PROTECTED]> wrote:

Hi,

In
master_localhost.err and tserver_localhost.err,
log4j:WARN No appenders could be found for logger (org.apache.accumulo.start.classloader.AccumuloClassLoader).
log4j:WARN Please initialize the log4j system properly.

monitor_localhost.err
log4j:WARN No appenders could be found for logger (org.apache.accumulo.start.classloader.AccumuloClassLoader).
log4j:WARN Please initialize the log4j system properly.
Thread "monitor" died null
java.lang.reflect.InvocationTargetException

 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
 at java.lang.reflect.Method.invoke(Method.java:597)
 at org.apache.accumulo.start.Main$1.run(Main.java:101)
 at java.lang.Thread.run(Thread.java:662)

Caused by: java.security.AccessControlException: access denied (javax.security.auth.AuthPermission getSubject)
 at java.security.AccessControlContext.checkPermission(AccessControlContext.java:374)
 at java.security.AccessController.checkPermission(AccessController.java:546)
 at java.lang.SecurityManager.checkPermission(SecurityManager.java:532)
 at javax.security.auth.Subject.getSubject(Subject.java:268)
 at org.apache.hadoop.security.UserGroupInformation.getCurrentUser(UserGroupInformation.java:471)
 at org.apache.hadoop.fs.FileSystem$Cache$Key.<init>(FileSystem.java:1668)
 at org.apache.hadoop.fs.FileSystem$Cache$Key.<init>(FileSystem.java:1661)
 at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:1529)
 at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:228)
 at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:111)
 at org.apache.accumulo.core.file.FileUtil.getFileSystem(FileUtil.java:550)
 at org.apache.accumulo.server.monitor.Monitor.main(Monitor.java:453)
 ... 6 more

Pls let me know whats the fix.

Thanks and Regards,
Navindran Gowrikumar

BSC-1, Next-Level 5th Floor, West Wing
34, IT Highway
PolarisFT-Navallur-Chennai

To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
From: John Vines <[EMAIL PROTECTED]>
Date: 07/13/2013 11:24PM

Subject: Re: Apach Accumulo Issue
Please check all of the .err files. If you're overexerting the memory available, the processes will die quickly and messages will be emitted there.

On Sat, Jul 13, 2013 at 11:55 AM, <[EMAIL PROTECTED]> wrote:

Hi Charles,

I set the root logger in the log4j.properties under accumulo/conf/ from INFO to DEBUG. Then bounced Accumulo.
Only tracer and gc is getting started.

tracer_localhost.localdomain.debug.log
08 06:48:03,669 [impl.ServerClient] WARN : There are no tablet servers: check that zookeeper and accumulo are running.
08 06:48:03,670 [impl.ServerClient] DEBUG: ClientService request failed null, retrying ...
org.apache.thrift.transport.TTransportException: Failed to connect to a server
 at org.apache.accumulo.core.client.impl.ThriftTransportPool.getAnyTransport(ThriftTransportPool.java:437)
 at org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:152)
 at org.apache.accumulo.core.client.impl.ServerClient.getConnection(Se
+
John Vines 2013-07-18, 16:41
+
navindran.sgk@... 2013-07-16, 15:31
+
Christopher 2013-07-11, 20:18