Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HDFS, mail # user - Namenode and Jobtracker dont start


Copy link to this message
-
Re: Namenode and Jobtracker dont start
Mohammad Tariq 2012-07-20, 14:58
Hello sir,

      If possible, could you please paste your config files??

Regards,
    Mohammad Tariq
On Fri, Jul 20, 2012 at 8:24 PM, Björn-Elmar Macek
<[EMAIL PROTECTED]> wrote:
> Hi together,
>
> well just stumbled upon this post:
> http://ankitasblogger.blogspot.de/2012/01/error-that-occured-in-hadoop-and-its.html
>
> And it says:
> "Problem: Hadoop-datanode job failed or datanode not running:
> java.io.IOException: File ../mapred/system/jobtracker.info could only be
> replicated to 0 nodes, instead of 1.
> ...
> Cause: You may also get this message due to permissions. May be JobTracker
> can not create jobtracker.info on startup."
>
> Since the file does not exist i think, this might be a probable reason for
> my errors. But why should the JobTracker not be able to create that file. It
> created several other directories on this node with easy via the slave.sh
> script that i started with the very same user that calls start-all.sh.
>
> Any help would be really appreciated.
>
>
> Am 20.07.2012 16:15, schrieb Björn-Elmar Macek:
>
> Hi Srinivas,
>
> thanks for your reply! I have been following your link and idea and been
> playing around alot, but still got problems with the connection (though they
> are different now):
>
> \_______ JAVA VERSION_________
> "which java" tells me it is 1.6.0_01. If i got it right version 1.7 got
> problems with ssh.
>
> \_______MY TESTS_____________
> According to your suggestion to look for processes running on that port i
> changed ports alot:
> When i was posting the first post of this thread. i was using ports 999 for
> namenode and 1000 for jobtracker.
> Since due to some reasons commands like "lsof -i" etc dont give me any
> output when usedin the cluster enviroment. So i started looking for ports
> that are in general unused by programs.
> When i changed the ports to 9004 and 9005 i got different errors which look
> very much like the ones you posted in the beginning of this year in the
> lucene section (
> http://lucene.472066.n3.nabble.com/Unable-to-start-hadoop-0-20-2-but-able-to-start-hadoop-0-20-203-cluster-td2991350.html
> ).
>
> It seems as if a DataNode can not communicate with the NameNode.
>
> The logs look like the following:
>
> \_______TEST RESULTS__________
> ########## A DataNode #############
> 2012-07-20 14:47:59,536 INFO
> org.apache.hadoop.hdfs.server.datanode.DataNode: STARTUP_MSG:
> /************************************************************
> STARTUP_MSG: Starting DataNode
> STARTUP_MSG:   host = its-cs102.its.uni-kassel.de/141.51.205.12
> STARTUP_MSG:   args = []
> STARTUP_MSG:   version = 1.0.2
> STARTUP_MSG:   build > https://svn.apache.org/repos/asf/hadoop/common/branches/branch-1.0.2 -r
> 1304954; compiled by 'hortonfo' on Sat Mar 24 23:58:21 UTC 2012
> ************************************************************/
> 2012-07-20 14:47:59,824 INFO org.apache.hadoop.metrics2.impl.MetricsConfig:
> loaded properties from hadoop-metrics2.properties
> 2012-07-20 14:47:59,841 INFO
> org.apache.hadoop.metrics2.impl.MetricsSourceAdapter: MBean for source
> MetricsSystem,sub=Stats registered.
> 2012-07-20 14:47:59,843 INFO
> org.apache.hadoop.metrics2.impl.MetricsSystemImpl: Scheduled snapshot period
> at 10 second(s).
> 2012-07-20 14:47:59,844 INFO
> org.apache.hadoop.metrics2.impl.MetricsSystemImpl: DataNode metrics system
> started
> 2012-07-20 14:47:59,969 INFO
> org.apache.hadoop.metrics2.impl.MetricsSourceAdapter: MBean for source ugi
> registered.
> 2012-07-20 14:48:26,792 INFO org.apache.hadoop.ipc.Client: Retrying connect
> to server: its-cs100/141.51.205.10:9005. Already tried 0 time(s).
> 2012-07-20 14:48:26,889 INFO
> org.apache.hadoop.hdfs.server.datanode.DataNode: Registered
> FSDatasetStatusMBean
> 2012-07-20 14:48:26,934 INFO
> org.apache.hadoop.hdfs.server.datanode.DataNode: Opened info server at 50010
> 2012-07-20 14:48:26,949 INFO
> org.apache.hadoop.hdfs.server.datanode.DataNode: Balancing bandwith is
> 1048576 bytes/s
> 2012-07-20 14:48:27,014 INFO org.mortbay.log: Logging to