Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo, mail # user - Re: [External]  Re: Accumulo (1.5.0) Master Will Not Start


Copy link to this message
-
Re: [External] Re: Accumulo (1.5.0) Master Will Not Start
John Vines 2013-08-27, 00:59
Which log directory are you checking?
On Mon, Aug 26, 2013 at 8:18 PM, Shipper, Jay [USA] <[EMAIL PROTECTED]>wrote:

>  It's not making any .out/.err files in the log directory, nor is it
> updating the accumulo master log file.
>
>  Here's the result of the command you suggested, following the point
> where the script connects to HDFS (I have substituted <host ip> for the
> actual IP):
> ---
>  + disown
> + SUDOPID=22238
> + sleep 5
> + sudo -u accumulo /usr/lib/accumulo/bin/accumulo master --address <host
> ip>
> + '[' -z 22238 ']'
> ++ ps --ppid 22238 -o pid> + PID> + '[' -z '' ']'
> + echo Failed
> Failed
> + return 1
> + RETVAL=1
> + exit 1
>  ---
>  *_________________*
>
> *Jay Shipper*
>
> Booz | Allen | Hamilton
>
> [EMAIL PROTECTED]
>
>   From: John Vines <[EMAIL PROTECTED]>
> Reply-To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>, "
> [EMAIL PROTECTED]" <[EMAIL PROTECTED]>
> Date: Monday, August 26, 2013 6:52 PM
> To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
> Subject: Re: [External] Re: Accumulo (1.5.0) Master Will Not Start
>
>   Including the .out and .err files? Try running it as bash -x
> /etc/init.d/accumulo-master start and see if you spot anything there.
>
>
> On Mon, Aug 26, 2013 at 6:48 PM, Shipper, Jay [USA] <[EMAIL PROTECTED]>wrote:
>
>>   As I mentioned, nothing is being logged in the master's logs when I
>> attempt to start the service.
>>  *_________________*
>>
>> *Jay Shipper*
>>
>> Booz | Allen | Hamilton
>>
>> 304 National Business Parkway
>>
>> Room 5048
>>
>> Annapolis Junction, MD 20701
>>
>> Phone: 301-419-5437
>>
>> [EMAIL PROTECTED]
>>
>>   From: John Vines <[EMAIL PROTECTED]>
>> Reply-To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>, "
>> [EMAIL PROTECTED]" <[EMAIL PROTECTED]>
>> Date: Monday, August 26, 2013 4:21 PM
>> To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
>> Subject: [External] Re: Accumulo (1.5.0) Master Will Not Start
>>
>>   Please check the various master logs and see if anything is being
>> reported there.
>>
>>
>> On Mon, Aug 26, 2013 at 4:10 PM, Shipper, Jay [USA] <[EMAIL PROTECTED]>wrote:
>>
>>>  Here is what is being logged to the console when I try to start the
>>> accumulo (1.5.0) master service:
>>> ---
>>>  $ sudo service accumulo-master start
>>> Not running
>>> Starting...
>>> 2013-08-26 19:46:41,674 [vfs.AccumuloVFSClassLoader] WARN : ignoring
>>> classpath entry file:///usr/lib/accumulo/lib/ext/[^.].*.jar
>>> 2013-08-26 19:46:43,342 [server.Accumulo] INFO : Attempting to talk to
>>> zookeeper
>>> 2013-08-26 19:46:43,505 [server.Accumulo] INFO : Zookeeper connected and
>>> initialized, attemping to talk to HDFS
>>> 2013-08-26 19:46:43,658 [server.Accumulo] INFO : Connected to HDFS
>>> Failed
>>>  ---
>>>
>>>  What could cause this behavior?  HDFS and Zookeeper both appear fine,
>>> the accumulo monitor shows the zookeeper servers, and all the other
>>> accumulo services are still up on their respective nodes.  Nothing is
>>> getting logged in our accumulo logs directory.
>>>
>>>  If you need any other information to make a diagnosis, just ask for
>>> what you need.  We have a working cluster with pretty much the same setup
>>> (EC2, CentOS, Hadoop 2, etc.), which is why we're very puzzled.
>>>
>>>  Thanks,
>>>  *_________________*
>>>
>>> *Jay Shipper*
>>>
>>> Booz | Allen | Hamilton
>>>
>>> [EMAIL PROTECTED]
>>>
>>
>>
>