Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> Compile does not work against Hadoop-1.0.0 - 1.0.2


+
Enis Söztutar 2013-04-25, 01:29
+
Andrew Purtell 2013-04-25, 18:13
+
Enis Söztutar 2013-04-25, 18:22
+
Andrew Purtell 2013-04-25, 18:28
+
Enis Söztutar 2013-04-25, 18:31
Copy link to this message
-
Re: Compile does not work against Hadoop-1.0.0 - 1.0.2
Doc'ing it seems good to me.  Here is a suggested change (if good, i'll
commit against an issue so we have a note of what Enis found):

durruti:trunk stack$ svn diff --force src/main/docbkx/
Index: src/main/docbkx/configuration.xml
==================================================================--- src/main/docbkx/configuration.xml (revision 1475995)
+++ src/main/docbkx/configuration.xml (working copy)
@@ -231,7 +231,7 @@
      </thead><tbody>
          <row><entry>Hadoop-0.20.205</entry><entry>S</entry>
 <entry>X</entry>           <entry>X</entry></row>
          <row><entry>Hadoop-0.22.x  </entry><entry>S</entry>
 <entry>X</entry>           <entry>X</entry></row>
-         <row><entry>Hadoop-1.0.x   </entry><entry>S</entry>
 <entry>S</entry>           <entry>S</entry></row>
+         <row><entry>Hadoop-1.0.3+<footnote><para>HBase requires hadoop
1.0.3 at a minimum; there is an issue where we cannot find KerberosUtil
compiling against earlier versions of Hadoop.</para></footnote>
</entry><entry>S</entry>          <entry>S</entry>
<entry>S</entry></row>
          <row><entry>Hadoop-1.1.x   </entry><entry>NT</entry>
<entry>S</entry>           <entry>S</entry></row>
          <row><entry>Hadoop-0.23.x  </entry><entry>X</entry>
 <entry>S</entry>           <entry>NT</entry></row>
          <row><entry>Hadoop-2.x     </entry><entry>X</entry>
 <entry>S</entry>           <entry>S</entry></row>

On Thu, Apr 25, 2013 at 11:31 AM, Enis Söztutar <[EMAIL PROTECTED]> wrote:

> No, not that I know of.
>
> That's why I suggested that one option to dealing with this issue is to
> just document this case, and move on.
>
> Enis
>
>
> On Thu, Apr 25, 2013 at 11:28 AM, Andrew Purtell <[EMAIL PROTECTED]
> >wrote:
>
> > Sure. That's the question I have too: Is there anything about 1.0.3 or
> > later which would be an incompatibility with 1.0.0 - 1.0.2 or prevent a
> > rolling upgrade?
> >
> >
> > On Thu, Apr 25, 2013 at 11:22 AM, Enis Söztutar <[EMAIL PROTECTED]>
> > wrote:
> >
> > > The only reason I see is that you might be stuck with an older version
> of
> > > Hadoop for some other reason.
> > >
> > > Enis
> > >
> > >
> > > On Thu, Apr 25, 2013 at 11:13 AM, Andrew Purtell <[EMAIL PROTECTED]
> > > >wrote:
> > >
> > > > Is there a valid reason for using a Hadoop version older than 1.0.3
> if
> > > > compiling up your own deploy?
> > > >
> > > >
> > > > On Wed, Apr 24, 2013 at 6:29 PM, Enis Söztutar <[EMAIL PROTECTED]>
> > > wrote:
> > > >
> > > > > While trying with older Hadoop versions, I noticed that we do not
> > > compile
> > > > > against hadoop versions older than 1.0.3.
> > > > >
> > > > > I think the programmatic kerberos jaas configuration broke the
> > compat:
> > > > > The error is:
> > > > >
> > > > > [ERROR]
> > > > >
> > > > >
> > > >
> > >
> >
> /Users/enis/projects/hbase/hbase-client/src/main/java/org/apache/hadoop/hbase/zookeeper/ZKUtil.java:[36,53]
> > > > > cannot find symbol
> > > > > symbol  : class KerberosUtil
> > > > > location: package org.apache.hadoop.security.authentication.util
> > > > > [ERROR]
> > > > >
> > > > >
> > > >
> > >
> >
> /Users/enis/projects/hbase/hbase-client/src/main/java/org/apache/hadoop/hbase/zookeeper/ZKUtil.java:[247,32]
> > > > > cannot find symbol
> > > > > symbol  : variable KerberosUtil
> > > > > location: class
> > > > org.apache.hadoop.hbase.zookeeper.ZKUtil.JaasConfiguration
> > > > >
> > > > >
> > > > > Should we fix this, or just document the case, and not work with
> > older
> > > > > hadoop versions than 1.0.3
> > > > >
> > > > > Enis
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > Best regards,
> > > >
> > > >    - Andy
> > > >
> > > > Problems worthy of attack prove their worth by hitting back. - Piet
> > Hein
> > > > (via Tom White)
> > > >
> > >
> >
> >
> >
> > --
> > Best regards,
> >
> >    - Andy
> >
> > Problems worthy of attack prove their worth by hitting back. - Piet Hein
> > (via Tom White)
> >
>
+
Jonathan Hsieh 2013-04-26, 00:21
+
Stack 2013-04-26, 04:11
+
Jonathan Hsieh 2013-04-26, 14:10
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB