Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> API not fully backwards compatible between 1.4.1 and 1.4.2


Copy link to this message
-
API not fully backwards compatible between 1.4.1 and 1.4.2
All,

I just ran into an issue after deploy 1.4.2. It appears that
IteratorUtil.generateInitialTableProperties() now requires a boolean and
the no-args invocation was deleted.[1]

Running the test/compat/diffAPI.pl script on 1.4.1. and 1.4.2 doesn't
show the changed API in IteratorUtil as I would expect it to. Is this
script expected to work? I know I didn't run it as part of checking the
1.4.2 release candidates.

- Josh

[1]
http://svn.apache.org/viewvc/accumulo/tags/1.4.2/src/core/src/main/java/org/apache/accumulo/core/iterators/IteratorUtil.java?r1=1397920&r2=1397921