Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> no 0.94 commits please


+
lars hofhansl 2013-03-06, 01:01
+
lars hofhansl 2013-03-06, 05:43
+
Jean-Marc Spaggiari 2013-03-06, 12:47
+
Ted 2013-03-06, 13:00
+
Jean-Marc Spaggiari 2013-03-06, 13:23
+
Jean-Marc Spaggiari 2013-03-06, 13:40
+
Matteo Bertozzi 2013-03-06, 13:46
+
Jean-Marc Spaggiari 2013-03-06, 13:50
+
Jean-Marc Spaggiari 2013-03-06, 13:58
Copy link to this message
-
Re: no 0.94 commits please
I don't think 1.7 is formally supported by HBase 0.94

Cheers

On Wed, Mar 6, 2013 at 5:58 AM, Jean-Marc Spaggiari <[EMAIL PROTECTED]
> wrote:

> Ok. It's working fine with JDK 1.7.0_13 when HBASE 6915 is applied. I
> will retry with Oracle JDKs 1.7.0_17 and Open JDK 6 and 7 to validate
> that it's working for all.
>
> Should we apply this fix in 0.94 branch? Or is 1.7 not supported by HBase
> yet?
>
> 2013/3/6 Jean-Marc Spaggiari <[EMAIL PROTECTED]>:
> > I'm able to reproduce that running the test locally in Eclipse if I
> > configure the project with JDK 1.7.0_13.... And it really lookes like
> > the 2 JIRA's pointed below.
> >
> > I can try to apply HBASE-6915 locally and re-test.
> >
> > 2013/3/6 Matteo Bertozzi <[EMAIL PROTECTED]>:
> >> I haven't looked at this problem but I remember a similar jdk6/jdk7
> >> difference HBASE-6915 <https://issues.apache.org/jira/browse/HBASE-6915
> >,
> >> HBASE-7119 <https://issues.apache.org/jira/browse/HBASE-7119>
> >>
> >> On Wed, Mar 6, 2013 at 1:40 PM, Jean-Marc Spaggiari <
> [EMAIL PROTECTED]
> >>> wrote:
> >>
> >>> Passed with OpenJDK 1.7
> >>>
> >>> Running org.apache.hadoop.hbase.io.TestHeapSize
> >>> Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.016
> sec
> >>>
> >>> Now I will run it into eclipse with Oracle JDK 1.7_13 and try to debug
> >>> it...
> >>>
> >>> 2013/3/6 Jean-Marc Spaggiari <[EMAIL PROTECTED]>:
> >>> > Hi Ted,
> >>> >
> >>> > It's also failing with 1.7_17
> >>> >
> >>> > Here is the output:
> >>> > Running org.apache.hadoop.hbase.io.TestHeapSize
> >>> > Tests run: 2, Failures: 2, Errors: 0, Skipped: 0, Time elapsed:
> >>> > 150.213 sec <<< FAILURE!
> >>> >
> >>> > Results :
> >>> >
> >>> > Failed tests:
> >>> > testNativeSizes(org.apache.hadoop.hbase.io.TestHeapSize):
> >>> > expected:<56> but was:<64>
> >>> >   testSizes(org.apache.hadoop.hbase.io.TestHeapSize): expected:<192>
> >>> > but was:<200>
> >>> >
> >>> > Tests run: 603, Failures: 2, Errors: 0, Skipped: 0
> >>> >
> >>> >
> >>> > Just re-started it with -X to figure what the issue is.
> >>> >
> >>> > 2013/3/6 Ted <[EMAIL PROTECTED]>:
> >>> >> The test passed on Jenkins.
> >>> >>
> >>> >> Can you give us more detail about the failure ?
> >>> >>
> >>> >> Thanks
> >>> >>
> >>> >> On Mar 6, 2013, at 4:47 AM, Jean-Marc Spaggiari <
> >>> [EMAIL PROTECTED]> wrote:
> >>> >>
> >>> >>> I got testNativeSizes failed 4 times in a row. I have not seen
> >>> >>> anything about that in the mailing lists.
> >>> >>>
> >>> >>> testNativeSizes and testSizes both failed.
> >>> >>>
> >>> >>> Does anyone have faced the same issue?
> >>> >>>
> >>> >>> I never faced that with 0.94.5. I will retry to entire test suite
> with
> >>> >>> it to see.
> >>> >>>
> >>> >>> JM
> >>> >>>
> >>> >>> 2013/3/6 lars hofhansl <[EMAIL PROTECTED]>:
> >>> >>>> All Clear!
> >>> >>>>
> >>> >>>>
> >>> >>>>
> >>> >>>>
> >>> >>>> ________________________________
> >>> >>>> From: lars hofhansl <[EMAIL PROTECTED]>
> >>> >>>> To: hbase-dev <[EMAIL PROTECTED]>
> >>> >>>> Sent: Tuesday, March 5, 2013 5:01 PM
> >>> >>>> Subject: no 0.94 commits please
> >>> >>>>
> >>> >>>> Cutting 0.94.6RC0 now.
> >>>
>
+
Jean-Marc Spaggiari 2013-03-06, 12:59
+
Lars Hofhansl 2013-03-06, 16:32
+
Jean-Marc Spaggiari 2013-03-06, 17:37
+
lars hofhansl 2013-03-07, 05:58
+
lars hofhansl 2013-03-08, 00:30
+
Jean-Marc Spaggiari 2013-03-08, 00:38
+
Ted Yu 2013-03-08, 05:05
+
lars hofhansl 2013-03-08, 05:08