Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Sqoop >> mail # user >> OraOop


Hi Venky,

Sure. No problem.

1) Checkout the latest Sqoop source code that already includes SQOOP-480
from the project repository and build. For details, please refer to the
following link:

https://cwiki.apache.org/confluence/display/SQOOP/Setting+up+Development+Environment

2) Replace the installed Sqoop jar with the one that you've just built. If
you installed Sqoop from rpm or deb, you can find the installed jar at
/usr/lib/sqoop/lib.

Please let me know if you have any further questions.

Thanks,
Cheolsoo

On Wed, Jul 4, 2012 at 7:42 PM, venkatesh warulu <[EMAIL PROTECTED]> wrote:

> Hi ,
>
> This is new area for me to explore ... Will you please provide me the
> steps to apply the patch *SQOOP-480*.
>
>
>
> Regards
> Venky
>   *From:* Cheolsoo Park <[EMAIL PROTECTED]>
> *To:* [EMAIL PROTECTED]
> *Cc:* [EMAIL PROTECTED]
> *Sent:* Thursday, July 5, 2012 4:05 AM
> *Subject:* Re: OraOop
>
> Hi Venky,
>
> Exception in thread "main"
> java.lang.NoSuchMethodError: com.cloudera.sqoop.manager.ImportJobContext.setConnManager(Lcom/cloudera/sqoop/manager/ConnManager;)V
>
>
> This is fixed in the upstream trunk. Please see SQOOP-480:
> https://issues.apache.org/jira/browse/SQOOP-480. Unfortunately, there is
> no official Sqoop release that include this fix, so you will have to apply
> the patch and rebuild Sqoop.
>
>  Thanks,
> Cheolsoo
>
>
> On Wed, Jul 4, 2012 at 12:13 PM, Kathleen Ting <[EMAIL PROTECTED]>wrote:
>
> Dear Venky,
>
> For faster resolution of Sqoop support issues, please subscribe to the
> Sqoop User mailing list by emailing: [EMAIL PROTECTED]
>
> Regarding your issue below, it could be that your version of Hadoop is
> not compatible with OraOop - what is your Hadoop version?
>
> Regards, Kathleen
>
> sqoop import  --connect
> jdbc:oracle:thin:@lyisdb01.dev.sgp.avagotech.net:1523:OPTCH --username
> system --password clone --table VENK -verbose
> 12/07/04 05:39:14 WARN tool.BaseSqoopTool: Setting your password on
> the command-line is insecure. Consider using -P instead.
> 12/07/04 05:39:14 DEBUG oraoop.OraOopUtilities: Enabled OraOop debug
> logging.
> 12/07/04 05:39:14 DEBUG oraoop.OraOopManagerFactory: Quest® Data
> Connector for Oracle and Hadoop can be called by Sqoop!
> 12/07/04 05:39:14 INFO manager.SqlManager: Using default fetchSize of 1000
> 12/07/04 05:39:15 DEBUG oraoop.OraOopUtilities: The Oracle table
> context has been derived from:
>         oracleConnectionUserName = system
>         tableStr = VENK
>         as:
>         owner : SYSTEM
>         table : VENK
> 12/07/04 05:39:15 INFO oraoop.OraOopManagerFactory:
> ***************************************************************
> *** Using Quest® Data Connector for Oracle and Hadoop 1.5.0 ***
> *** Copyright 2012 Quest Software, Inc.                     ***
> *** ALL RIGHTS RESERVED.                                    ***
> ***************************************************************
> 12/07/04 05:39:15 INFO oraoop.OraOopManagerFactory: Oracle Database
> version: Oracle Database 11g Enterprise Edition Release 11.1.0.7.0 -
> 64bit Production
> 12/07/04 05:39:15 INFO oraoop.OraOopManagerFactory: This Oracle
> database is not a RAC.
> 12/07/04 05:39:15 WARN conf.Configuration: mapred.map.max.attempts is
> deprecated. Instead, use mapreduce.map.maxattempts
> 12/07/04 05:39:15 INFO tool.CodeGenTool: Beginning code generation
> 12/07/04 05:39:15 DEBUG oraoop.OraOopOracleQueries: getTableColumns() :
> sql > SELECT column_name, data_type  FROM dba_tab_columns WHERE owner = ?
> and table_name = ?  and (DATA_TYPE IN
>
> ('BINARY_DOUBLE','BINARY_FLOAT','BLOB','CHAR','CLOB','DATE','FLOAT','LONG','NCHAR','NCLOB','NUMBER','NVARCHAR2','RAW','ROWID','URITYPE','VARCHAR2')
> OR DATA_TYPE LIKE 'INTERVAL YEAR(%) TO MONTH' OR DATA_TYPE LIKE
> 'INTERVAL DAY(%) TO SECOND(%)' OR DATA_TYPE LIKE 'TIMESTAMP(%)' OR
> DATA_TYPE LIKE 'TIMESTAMP(%) WITH TIME ZONE' OR DATA_TYPE LIKE
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB