Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Hbase tables disappear


Copy link to this message
-
Re: Hbase tables disappear
On Tue, Jan 15, 2013 at 1:07 AM, Ibrahim Yakti <[EMAIL PROTECTED]> wrote:

> The root directory is set to /var/lib/hbase/
>
> The count issue is still exist:
>
> *Sqoop: *
> 13/01/15 08:55:23 INFO mapreduce.ImportJobBase: Retrieved 1754285 records.
>
> *MySQL:*
> +----------+
> | count(1) |
> +----------+
> |  1754303 |
> +----------+
>
>
> *HBase:*
> 104210 row(s) in 11.4980 seconds
>
> running count command five minutes later:
> 327230 row(s) in 18.4020 seconds
>
>
>
> *Hive *(using HBase as external table)*:*
> OK
> 104222
> Time taken: 41.971 seconds
>
> running same command five minutes later:
> OK
> 454038
> Time taken: 149.328 seconds
>
>
> Any idea what is going on or what is missing?
>
>

Upload is still happening?

HBase does not usually lose data so I'd say the issue has to do w/ how you
are doing your upload or it is some characteristic of your data -- or even
of the schema you have chosen for hbase.

Try with a little data first... a subselect.  Confirm that works and go up
from there.  If data is missing, try figure what is missing and if the
missing data has a common characteristic.

Good luck,
St.Ack
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB