Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase, mail # user - (HBASE-5261)HBase 0.94 cerification for JDK7


+
anil gupta 2013-09-03, 23:26
+
lars hofhansl 2013-09-04, 00:35
+
anil gupta 2013-09-04, 05:03
+
anil gupta 2013-09-04, 05:06
Copy link to this message
-
Re: (HBASE-5261)HBase 0.94 cerification for JDK7
Elliott Clark 2013-09-04, 05:26
Cloudera (my employer) has certified their distribution(CDH4.2+) on
JDK7.  That includes HBase 94.  I'm sure they would answer questions
about what was tested, on their mailing lists or forums.

I imagine that Hortonworks has done similar testing though I am not as
well versed in it.

I personally been running a test cluster with Integration tests (for
0.96) on jdk7, G1 gc, and 30 gig heaps for a couple of months now.
There have been a couple of times that the region servers have core
dumped because of the JVM.  However I would say the region servers are
some what stable with JDK 1.07.15 and the G1gc. My test cluster is
pretty taxed and your milage might vary; it's worth testing on your
workload.

I'm currently upgrading the jvm to release 25 hoping that the core
dumps will be solved.

On Tue, Sep 3, 2013 at 10:06 PM, anil gupta <[EMAIL PROTECTED]> wrote:
> Also, if HBase0.94 is officially certified to work with JDK7 then it will
> save duplicate work from Individual users like me and you. Currently GC
> with big JVM heaps is a big concern with HBase. If users will get options
> to use G1GC then it might alleviate some pains of many HBase users.
>
>
> On Tue, Sep 3, 2013 at 10:03 PM, anil gupta <[EMAIL PROTECTED]> wrote:
>
>> Hi Lars,
>>
>> Even if we setup Jenkins with JDK7 then also we wont be able to use JDK7
>> in prod HBase cluster. Beacuse, as per our process, we can only use the JDK
>> that is certified by Apache HBase. If we don't follow this rule then IT/DBA
>> folks wont support us. That's why i am looking for JDK7 certification of
>> HBase0.94. It would be great if an official certification can be done.
>>
>> Thanks,
>> Anil
>>
>>
>> On Tue, Sep 3, 2013 at 5:35 PM, lars hofhansl <[EMAIL PROTECTED]> wrote:
>>
>>> We (Salesforce) are using HBase with JDK7. No issues seen so far.
>>>
>>> 0.94 is not "officially certified" to work on JDK7 (we have no JDK7
>>> jenkins, etc).
>>>
>>> It might be good to setup a JDK7 jenkins for 0.94. Any objections to
>>> doing that?
>>>
>>> -- Lars
>>>
>>>
>>>
>>> ----- Original Message -----
>>> From: anil gupta <[EMAIL PROTECTED]>
>>> To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
>>> Cc:
>>> Sent: Tuesday, September 3, 2013 4:26 PM
>>> Subject: (HBASE-5261)HBase 0.94 cerification for JDK7
>>>
>>> Hi All,
>>>
>>> We are thinking of running HBase(we have JVM heaps larger than 25 GB) with
>>> JDK7 to use G1 garbage collection, but as a precaution we would like HBase
>>> to be certified with JDK7. I see this ticket for same:
>>> https://issues.apache.org/jira/browse/HBASE-5261
>>> Above havent had any activity from November, 2012. Are there any timelines
>>> to certify HBase 0.94 with JDK7?
>>>
>>> --
>>> Thanks & Regards,
>>> Anil Gupta
>>>
>>>
>>
>>
>> --
>> Thanks & Regards,
>> Anil Gupta
>>
>
>
>
> --
> Thanks & Regards,
> Anil Gupta
+
anil gupta 2013-09-04, 05:42
+
Elliott Clark 2013-09-04, 06:04
+
anil gupta 2013-09-04, 06:17
+
Elliott Clark 2013-09-04, 06:29
+
Stack 2013-09-04, 21:32
+
anil gupta 2013-09-05, 04:11
+
Andrew Purtell 2013-09-04, 21:14
+
anil gupta 2013-09-05, 04:16