Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive >> mail # dev >> Review Request: Adding review request for https://issues.apache.org/jira/browse/HIVE-3559


Copy link to this message
-
Re: Review Request: Adding review request for https://issues.apache.org/jira/browse/HIVE-3559

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/9248/#review16030
-----------------------------------------------------------

ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java
<https://reviews.apache.org/r/9248/#comment34329>

    It would be good to implement left() in this patch since the extra code required is virtually identical to what you have already written.
    
    Also, is it possible to change the name to "right()", or does that cause problems with the parser?

ql/src/test/queries/clientpositive/udf_right.q
<https://reviews.apache.org/r/9248/#comment34327>

    Please add tests for the following cases:
    
    * string parameter is NULL
    * length parameter is NULL
    * length parameter is 0
    * length parameter is greater than the length of the string
    * length parameter is negative
    
    Note that in every case the correct behavior is whatever MySQL's version of right() does.
- Carl Steinbach
On Feb. 1, 2013, 11:07 a.m., Arun A K wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/9248/
> -----------------------------------------------------------
>
> (Updated Feb. 1, 2013, 11:07 a.m.)
>
>
> Review request for hive.
>
>
> Description
> -------
>
> Patch attached for https://issues.apache.org/jira/browse/HIVE-3559
>
>
> Diffs
> -----
>
>   ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java fc0256c
>   ql/src/java/org/apache/hadoop/hive/ql/udf/UDFRightSubstring.java PRE-CREATION
>   ql/src/test/queries/clientpositive/udf_right.q PRE-CREATION
>   ql/src/test/results/clientpositive/udf_right.q.out PRE-CREATION
>
> Diff: https://reviews.apache.org/r/9248/diff/
>
>
> Testing
> -------
>
> Test cases added, https://issues.apache.org/jira/browse/HIVE-3559
>     udf_right.q
>     udf_right.q.out
>
>
> Thanks,
>
> Arun A K
>
>