Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Sqoop >> mail # dev >> [VOTE] Sqoop 1.4.2 release


+
abhijeet gaikwad 2012-08-08, 08:56
+
alo alt 2012-08-08, 09:12
+
Kathleen Ting 2012-08-09, 18:41
Copy link to this message
-
Re: [VOTE] Sqoop 1.4.2 release
-1

I am really sorry for -1, but I think that the RC has a critical issue,
that is introduced by myself. I have tested the RC against CDH4.0 MR1
cluster, and I see the following problem while running an import job:

12/08/10 11:54:28 INFO mapred.JobClient: Task Id :
attempt_201208101150_0001_m_000000_0, Status : FAILED
Error:
org.hsqldb.DatabaseURL.parseURL(Ljava/lang/String;ZZ)Lorg/hsqldb/persist/HsqlProperties;
12/08/10 11:54:32 INFO mapred.JobClient: Task Id :
attempt_201208101150_0001_m_000000_1, Status : FAILED
Error:
org.hsqldb.DatabaseURL.parseURL(Ljava/lang/String;ZZ)Lorg/hsqldb/persist/HsqlProperties;
12/08/10 11:54:35 INFO mapred.JobClient: Task Id :
attempt_201208101150_0001_m_000000_2, Status : FAILED
Error:
org.hsqldb.DatabaseURL.parseURL(Ljava/lang/String;ZZ)Lorg/hsqldb/persist/HsqlProperties;
12/08/10 11:54:39 INFO mapred.JobClient: Job complete: job_201208101150_0001

As can be seen, this is a regression from "SQOOP-519: Update the version of
hsqldb decadency to 2.0.0". Even though we set HADOOP_USER_CLASSPATH_FIRST
in sqoop-configure.sh as discussed in SQOOP-524, tasks still pick up
Hsqldb-1.8.x that is present in classpath.

There has been some discussion about Hsqldb dependency in YARN, and they
moved the hsqldb-2.x jar out of Hadoop classpath. (Please see MAPREDUCE-4498
for details.). So we no longer have the hsqldb-2.x jar in Hadoop classpath,
and upgrading to hsqldb-2.x is no longer needed at all. I suggest that we
should revert SQOOP-519 and SQOOP-524 to avoid any potential issues due to
conflicting hsqldb jars in classpath.

I will file a upstream jira and attach the patch that I have. I
really apologize for all the inconvenience, but I think that this is
necessary. Again, this is all my fault. Sorry.

Thanks,
Cheolsoo
On Thu, Aug 9, 2012 at 11:41 AM, Kathleen Ting <[EMAIL PROTECTED]> wrote:

> +1
>
> * Verified md5sums
> * Verified necessary files were present at top level: NOTICE.txt,
> LICENSE.txt
> * CHANGELOG.txt looks up-to-date
> * Verified all unit tests (ant test)
>
> Thanks,
> Kathleen
>
> On Wed, Aug 8, 2012 at 2:12 AM, alo alt <[EMAIL PROTECTED]> wrote:
> > +1
> >
> >
> > abhijeet gaikwad wrote:
> >>
> >>
> >> Hi Devs,
> >> This is the first TopLevel release for Apache Sqoop, version 1.4.2
> >>
> >> *** Please cast your vote by [3 working days after sending] ***
> >>
> >> Details:
> >>
> >> 1. The list of fixed issues:
> >>
> >>
> http://svn.apache.org/repos/asf/sqoop/branches/branch-1.4.2/CHANGELOG.txt
> >> 2. The tarball (*.tar.gz), signature (*.asc), checksum (*.md5), and test
> >> result (log/*.ant_test.log):
> >> http://people.apache.org/~jarcec/sqoop-1.4.2-rc0/
> >> 3. The tag to be voted upon:
> >> http://svn.apache.org/repos/asf/sqoop/tags/release-1.4.2-rc0
> >> 4. The KEYS file:
> >> http://www.apache.org/dist/sqoop/KEYS
> >>
> >> Thanks,
> >> Abhijeet
>
+
Jarek Jarcec Cecho 2012-08-12, 19:42
+
Cheolsoo Park 2012-08-12, 22:23
+
abhijeet gaikwad 2012-08-16, 18:41
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB