Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - Connection error while usinh HBase client API for pseudodistrbuted mode


Copy link to this message
-
Re: Connection error while usinh HBase client API for pseudodistrbuted mode
Mohammad Tariq 2012-07-03, 14:28
What do you mean by "I tried starting Hbase master manually and I got
this error."??..By manually do you mean through the shell??How were
you trying to do it earlier??And if possible could you please post the
modified core-site.xml and hbase-site.xml files.

Regards,
    Mohammad Tariq
On Tue, Jul 3, 2012 at 7:41 PM, AnandaVelMurugan Chandra Mohan
<[EMAIL PROTECTED]> wrote:
> Thanks for the link.
>
> I followed the link and fixed my hdfs url too.
>
> But when I start hbase, hbase master and zookeeper processes are not
> starting
>
> I tried starting Hbase master manually and I got this error.
>
> ERROR master.HMasterCommandLine: Failed to start master
> java.io.IOException: CRC check failed
>
> Do you have any idea?
> On Tue, Jul 3, 2012 at 6:41 PM, Mohammad Tariq <[EMAIL PROTECTED]> wrote:
>
>> Not a prob..I was expecting this after looking at the config
>> file..First of all your "hbase.rootdir" property must contain the
>> "complete" value of the "fs.default.name" property in your hadoop's
>> "core-site.xml" file.(This includes "port no" also)..After that just
>> add the following properties in your hbase-site.xml file and let me
>> know if it is works for you.
>>
>> <property>
>>         <name>hbase.cluster.distributed</name>
>>         <value>true</value>
>> </property>
>>
>> <property>
>>   <name>hbase.zookeeper.quorum</name>
>>   <value>localhost</value>
>> </property>
>> <property>
>>     <name>dfs.replication</name>
>>     <value>1</value>
>> </property>
>> <property>
>>       <name>hbase.zookeeper.property.clientPort</name>
>>       <value>2181</value>
>>       <description>Property from ZooKeeper's config zoo.cfg.
>>       The port at which the clients will connect.
>>       </description>
>>     </property>
>>  <property>
>>
>> For detailed help you can visit this link -
>> http://cloudfront.blogspot.in/2012/06/how-to-configure-habse-in-pseudo.html
>> ,
>> if you want.
>>
>> Regards,
>>     Mohammad Tariq
>>
>>
>> On Tue, Jul 3, 2012 at 6:31 PM, AnandaVelMurugan Chandra Mohan
>> <[EMAIL PROTECTED]> wrote:
>> > Sorry. I tried list and it returned 0 as no table exists. Then I posted
>> > this question.
>> >
>> > Now when I try create table now, shell is hanging and I get following
>> > exception
>> >
>> > org.apache.hadoop.hbase.client.RetriesExhaustedException: Failed setting
>> up
>> > proxy interface org.apache.hadoop.hbase.ipc.HRegionInterface to
>> localhost/
>> > 127.0.0.1:39591
>> >
>> > So I feel issue is with HBase and not with client API. Let me fix this
>> > issue and try client API.
>> >
>> > Meanwhile, do you have any idea on this issue?
>> >
>> > On Tue, Jul 3, 2012 at 6:10 PM, Mohammad Tariq <[EMAIL PROTECTED]>
>> wrote:
>> >
>> >> Are you sure about the Hbase shell???Are you able to create tables ,
>> >> or list the tables through shell??
>> >>
>> >> Regards,
>> >>     Mohammad Tariq
>> >>
>> >>
>> >> On Tue, Jul 3, 2012 at 5:41 PM, Michael Segel <
>> [EMAIL PROTECTED]>
>> >> wrote:
>> >> > What's the status of Hadoop and IPV6 vs IPV4?
>> >> >
>> >> > On Jul 3, 2012, at 7:07 AM, AnandaVelMurugan Chandra Mohan wrote:
>> >> >
>> >> >> Hi,
>> >> >>
>> >> >> These are text from the files
>> >> >>
>> >> >> /etc/hosts
>> >> >>
>> >> >> 127.0.0.1       localhost
>> >> >>
>> >> >>
>> >> >> # The following lines are desirable for IPv6 capable hosts
>> >> >> ::1     localhost ip6-localhost ip6-loopback
>> >> >> fe00::0 ip6-localnet
>> >> >> ff00::0 ip6-mcastprefix
>> >> >> ff02::1 ip6-allnodes
>> >> >> ff02::2 ip6-allrouters
>> >> >>
>> >> >> hbase-site.xml
>> >> >>
>> >> >> <configuration>
>> >> >> <property>
>> >> >>      <name>hbase.rootdir</name>
>> >> >>      <value>hdfs://localhost/user/eucalyptus/hbase</value>
>> >> >>      <description>The directory shared by RegionServers.
>> >> >>      </description>
>> >> >>    </property>
>> >> >> </configuration>
>> >> >>
>> >> >>
>> >> >> On Tue, Jul 3, 2012 at 4:14 PM, Mohammad Tariq <[EMAIL PROTECTED]>
>> >> wrote:
>> >> >>
>> >> >>> Can you paste the contents of your /etc/hosts and hbase-site.xml