Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop, mail # dev - mvn eclipse:eclipse failure on windows


Copy link to this message
-
mvn eclipse:eclipse failure on windows
Uma Maheswara Rao G 2013-07-07, 15:28
Hi,

I am seeing this failure on windows while executing mvn eclipse:eclipse
command on trunk.

See the following trace:

[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-eclipse-plugin:2.8
:eclipse (default-cli) on project hadoop-common: Request to merge when
'filterin
g' is not identical. Original=resource src/main/resources:
output=target/classes
, include=[], exclude=[common-version-info.properties|**/*.java],
test=false, fi
ltering=false, merging with=resource src/main/resources:
output=target/classes,
include=[common-version-info.properties], exclude=[**/*.java], test=false,
filte
ring=true -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
swit
ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please rea
d the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
xception
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the
command

[ERROR]   mvn <goals> -rf :hadoop-common
E:\Hadoop-Trunk>

any idea for resolving it.

With 'org.apache.maven.plugins:maven-eclipse-plugin:2.6:eclipse' seems to
be no failures but  I am seeing following exception while running tests.
java.lang.UnsatisfiedLinkError:
org.apache.hadoop.io.nativeio.NativeIO$Windows.access0(Ljava/lang/String;I)Z
    at org.apache.hadoop.io.nativeio.NativeIO$Windows.access0(Native Method)
    at
org.apache.hadoop.io.nativeio.NativeIO$Windows.access(NativeIO.java:423)
    at org.apache.hadoop.fs.FileUtil.canWrite(FileUtil.java:952)
    at
org.apache.hadoop.hdfs.server.common.Storage$StorageDirectory.analyzeStorage(Storage.java:451)
    at
org.apache.hadoop.hdfs.server.namenode.FSImage.recoverStorageDirs(FSImage.java:282)
    at
org.apache.hadoop.hdfs.server.namenode.FSImage.recoverTransitionRead(FSImage.java:200)
    at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.loadFSImage(FSNamesystem.java:696)
    at
org.apache.hadoop.hdfs.server.namenode.FSNamesystem.loadFromDisk(FSNamesystem.java:530)
    at
org.apache.hadoop.hdfs.server.namenode.NameNode.loadNamesystem(NameNode.java:401)
    at
org.apache.hadoop.hdfs.server.namenode.NameNode.initialize(NameNode.java:435)
    at
org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:607)
    at
org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:592)
    at
org.apache.hadoop.hdfs.server.namenode.NameNode.createNameNode(NameNode.java:1172)
    at
org.apache.hadoop.hdfs.MiniDFSCluster.createNameNode(MiniDFSCluster.java:895)
    at
org.apache.hadoop.hdfs.MiniDFSCluster.createNameNodesAndSetConf(MiniDFSCluster.java:786)
    at
org.apache.hadoop.hdfs.MiniDFSCluster.initMiniDFSCluster(MiniDFSCluster.java:644)
    at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:334)
    at
org.apache.hadoop.hdfs.MiniDFSCluster$Builder.build(MiniDFSCluster.java:316)
    at
org.apache.hadoop.hdfs.server.namenode.ha.TestHASafeMode.setupCluster(TestHASafeMode.java:87)

Not sure what I missed here. Any idea what could be wrong here?

Regards,
Uma