Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo, mail # dev - Accumulo build error


Copy link to this message
-
Re: Accumulo build error
David Medinets 2013-06-25, 14:49
Can the build process you are using have a check for 'rpmbuild' as is
currently done for the 'thrift' command?
On Mon, Jun 24, 2013 at 8:35 AM, Andres Danter <[EMAIL PROTECTED]> wrote:

> Alright, now I'm embarrassed.  Thanks, Mike.  Apparently rpmbuild is not
> installed.  I should have known that, but since I was doing thing through
> Maven, I forgot to check.
>
> Andres
>
>
> On Mon, Jun 24, 2013 at 8:28 AM, Mike Drob <[EMAIL PROTECTED]> wrote:
>
> > Do you have rpmbuild installed?
> > On Jun 24, 2013 8:20 AM, "Andres Danter" <[EMAIL PROTECTED]> wrote:
> >
> > > Hi Josh,
> > >
> > > That was very helpful.  It got me passed the tests and my build was
> > > successful.  I'm now trying to build the RPM for Accumulo 1.4.3, but
> I'm
> > > getting resistance there too.  I'm running the command:
> > >
> > > mvn rpm:rpm -N
> > >
> > > All I'm getting for an error is an echo of the string of commands it is
> > > trying to execute.
> > >
> > > [ERROR] Failed to execute goal
> > > org.codehaus.mojo:rpm-maven-plugin:2.0-beta-2:rpm (default-cli) on
> > project
> > > accumulo: RPM build execution returned: '127' executing '/bin/sh -c cd
> > > /home/adanter/accumulo/accumulo-1.4.3/target/rpm/SPECS && rpmbuild -bb
> > > --buildroot /home/adanter/accumulo/accumulo-1.4.3/target/rpm/buildroot
> > > --define '_topdir /home/adanter/accumulo/accumulo-1.4.3/target/rpm'
> > > --target amd64 accumulo.spec'
> > >
> > > I feel like there is something I may have to do with Maven or its
> plugin.
> > >
> > > Thanks again for the help earlier.
> > >
> > > Andres
> > >
> > >
> > > On Sun, Jun 23, 2013 at 10:17 PM, Josh Elser <[EMAIL PROTECTED]>
> > wrote:
> > >
> > > > Andres,
> > > >
> > > > That test is known to be a little tight on the timings.
> > > >
> > > > If your system isn't beefy enough to run it in the expected timings,
> > you
> > > > can remove the Test annotation on the method, reduce the number of
> > > threads
> > > > that test will run, or just build the tag without running tests (mvn
> > > > package -DskipTests).
> > > >
> > > > - Josh
> > > >
> > > >
> > > > On 06/23/2013 09:42 PM, Andres Danter wrote:
> > > >
> > > >> Hi all,
> > > >>
> > > >> I'm having some problems building Accumulo 1.4.3.  It keeps failing
> an
> > > >> "InMemoryMapTest" in the tabletServer portion.  I'm including a link
> > to
> > > a
> > > >> document listing the errors I keep getting and the details of the
> > > platform
> > > >> and the environment I'm using.
> > > >>
> > > >> https://docs.google.com/file/**d/**0BxBY29P7A1RgaFhKRGFrWEFXX1k/**
> > > >> edit?usp=sharing<
> > >
> >
> https://docs.google.com/file/d/0BxBY29P7A1RgaFhKRGFrWEFXX1k/edit?usp=sharing
> > > >
> > > >>
> > > >> Any help getting me past this issue is appreciated, since I'm
> already
> > > >> behind on my project.
> > > >>
> > > >> Thanks,
> > > >>
> > > >> Andres
> > > >>
> > > >>
> > > >
> > >
> >
>