Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Avro >> mail # dev >> Ruby tests failing on new environment


+
Christopher McConnell 2012-12-20, 15:14
Copy link to this message
-
Re: Ruby tests failing on new environment
Try `gem install echoe`.

I'd like to remove the echoe dependency, actually. I may submit a
patch for that.

Martin

On 20 December 2012 07:14, Christopher McConnell
<[EMAIL PROTECTED]> wrote:
> Hello all,
>
> I'm starting the process of downloading/building/testing the Avro source,
> all went well except for the Ruby testing. Here is some information, not
> sure if this is my environment, or my ignorance. :-)
>
> Avro: latest trunk (pulled 12/19)
> OS: CentOS 6.2
> Linux: 2.6.32-220.el6.x86_64
> Rake: 0.8.7
> Ruby 1.8.7
>
> Execution of Ruby clean and test:
>
> [ctm@localhost ruby]$ rake --trace clean test
> (in /home/ctm/avro-trunk/lang/ruby)
> rake aborted!
> no such file to load -- echoe
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
> /home/ctm/avro-trunk/lang/ruby/Rakefile:18
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2382:in `load'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2382:in
> `raw_load_rakefile'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2016:in `load_rakefile'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2067:in
> `standard_exception_handling'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2015:in `load_rakefile'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1999:in `run'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2067:in
> `standard_exception_handling'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1997:in `run'
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
> /usr/bin/rake:19:in `load'
> /usr/bin/rake:19
>
> Any insights are appreciated! If there is more information that is needed,
> please let me know.
>
> Cheers,
> Chris
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB