Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Pig >> mail # user >> Failure to run pig jobs using HbaseStorage in Oozie


+
Praveen Bysani 2013-03-14, 09:28
Copy link to this message
-
Re: Failure to run pig jobs using HbaseStorage in Oozie
Hi Praveen,
   Are you running a secure cluster - secure hadoop and hbase? Can you
check what is the stacktrace on the pig launcher job log of Hadoop Oozie?

Regards,
Rohini
On Thu, Mar 14, 2013 at 2:28 AM, Praveen Bysani <[EMAIL PROTECTED]>wrote:

> Hi,
>
> I am trying to run a simple pig script that uses HbaseStorage class to load
> data from a hbase table. The pig script runs perfectly fine when run
> standalone in mapreduce mode. But when i submit it as a action in oozie
> workflow, the job always fails. The oozie job log for that workflow gives
> following errrors which is not very useful,
>
> JOB[0000004-130312101540251-oozie-oozi-W]
> ACTION[0000004-130312101540251-oozie-oozi-W@pig-node] action completed,
> external ID [job_201303111007_0043]
> 2013-03-14 08:41:22,658 WARN
> org.apache.oozie.action.hadoop.PigActionExecutor: USER[hadoopuser] GROUP[-]
> TOKEN[] APP[pig-wf] JOB[0000004-130312101540251-oozie-oozi-W]
> ACTION[0000004-130312101540251-oozie-oozi-W@pig-node] *Launcher
> ERROR,*reason: Main class
> *[org.apache.oozie.action.hadoop.PigMain], exit code [2]*
> 2013-03-14 08:41:22,833 INFO org.apache.oozie.command.wf.ActionEndXCommand:
> USER[hadoopuser] GROUP[-] TOKEN[] APP[pig-wf]
> JOB[0000004-130312101540251-oozie-oozi-W]
> ACTION[0000004-130312101540251-oozie-oozi-W@pig-node] ERROR is considered
> as FAILED for SLA
> 2013-03-14 08:41:22,892 INFO
> org.apache.oozie.command.wf.ActionStartXCommand: USER[hadoopuser] GROUP[-]
> TOKEN[] APP[pig-wf] JOB[0000004-130312101540251-oozie-oozi-W]
> ACTION[0000004-130312101540251-oozie-oozi-W@fail] Start action
> [0000004-130312101540251-oozie-oozi-W@fail] with user-retry state :
> userRetryCount [0], userRetryMax [0], userRetryInterval [10]
> 2013-03-14 08:41:22,893 WARN
> org.apache.oozie.command.wf.ActionStartXCommand: USER[hadoopuser] GROUP[-]
> TOKEN[] APP[pig-wf] JOB[0000004-130312101540251-oozie-oozi-W]
> ACTION[0000004-130312101540251-oozie-oozi-W@fail]
> [***0000004-130312101540251-oozie-oozi-W@fail***]Action status=DONE
> 2013-03-14 08:41:22,893 WARN
> org.apache.oozie.command.wf.ActionStartXCommand: USER[hadoopuser] GROUP[-]
> TOKEN[] APP[pig-wf] JOB[0000004-130312101540251-oozie-oozi-W]
> ACTION[0000004-130312101540251-oozie-oozi-W@fail]
> [***0000004-130312101540251-oozie-oozi-W@fail***]Action updated in DB!
> 2013-03-14 08:41:22,997 WARN
> org.apache.oozie.command.coord.CoordActionUpdateXCommand: USER[hadoopuser]
> GROUP[-] TOKEN[] APP[pig-wf] JOB[0000004-130312101540251-oozie-oozi-W]
> ACTION[-] E1100: Command precondition does not hold before execution, [,
> coord action is null], Error Code: E1100
>
>
> I did some searching and found that a patch has been deployed for this
> issue, based on the discussion here
> https://issues.apache.org/jira/browse/PIG-3206. However i am not sure how
> i
> can use that patch in my case. Someone help me resolve this.
>
> My current installation versions are as follows,
> Hadoop: CDH 4
> Pig: 0.10
> Oozie: 3.3.0
>
> --
> Regards,
> Praveen Bysani
> http://www.praveenbysani.com
>
+
Praveen Bysani 2013-03-15, 04:19
+
Rohini Palaniswamy 2013-03-15, 15:08
+
Praveen Bysani 2013-03-19, 04:16
+
Rohini Palaniswamy 2013-03-19, 20:45