Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Flume >> mail # user >> flume-ng script error...


Copy link to this message
-
Re: flume-ng script error...
OK, are you setting HADOOP_CLASSPATH in your hadoop-env.sh?

If so, it should be something like:

export HADOOP_CLASSPATH=$HADOOP_CLASSPATH:whatever"

or

if [[ -z $HADOOP_CLASSPATH ]]
then
  export HADOOP_CLASSPATH="whatever"
else
  export HADOOP_CLASSPATH=$HADOOP_CLASSPATH:whatever"
fi

On Thu, Nov 15, 2012 at 11:16 AM, Dan Young <[EMAIL PROTECTED]> wrote:
> http://pastebin.com/sn1ThHmm
>
> Dano
>
>
> On Thu, Nov 15, 2012 at 10:08 AM, Brock Noland <[EMAIL PROTECTED]> wrote:
>>
>> Could you put
>>
>> set -x
>>
>> at the very top of the script, post the entire output to pastebin, and
>> send us the link?
>>
>> Brock
>>
>> On Thu, Nov 15, 2012 at 11:06 AM, Dan Young <[EMAIL PROTECTED]> wrote:
>> > I nuked the previous  apache-flume-1.3.0/ dir and still get the
>> > error....
>> >
>> > Regards,
>> >
>> > Dano
>> >
>> >
>> > On Thu, Nov 15, 2012 at 10:02 AM, Alexander Alten-Lorenz
>> > <[EMAIL PROTECTED]> wrote:
>> >>
>> >> Hi,
>> >>
>> >> sounds like you have other jars in path (previous installations?),
>> >> which
>> >> mess up your new build. Do you have tried to start the new one from a
>> >> different directory?
>> >>
>> >> cheers
>> >> - Alex
>> >>
>> >>
>> >>
>> >> On Nov 15, 2012, at 5:10 PM, Dan Young <[EMAIL PROTECTED]> wrote:
>> >>
>> >> > I'm testing the spooling directory source in 1.3.  Last night I did a
>> >> > git
>> >> > pull/mvn install on the 1.3 branch, and now I'm getting the following
>> >> > error
>> >> > when I run /bin/flume-ng
>> >> >
>> >> > Exception in thread "main" java.lang.NoClassDefFoundError:
>> >> > org/apache/flume/tools/GetJavaProperty
>> >> > Caused by: java.lang.ClassNotFoundException:
>> >> > org.apache.flume.tools.GetJavaProperty
>> >> > at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>> >> > at java.security.AccessController.doPrivileged(Native Method)
>> >> > at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>> >> > at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>> >> > at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>> >> > at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>> >> >
>> >> >
>> >> >
>> >> > I did a diff on the previous flume-ng script, copied it over and ran
>> >> > bin/flume-ng without any such error.  Here's the diff
>> >> >
>> >> > diff flume-ng flume-ng.PREVIOUS
>> >> > 74c74
>> >> > <         java.library.path)
>> >> > ---
>> >> >>        java.library.path 2>/dev/null)
>> >> > 93c93
>> >> > <     HADOOP_CLASSPATH=$($HADOOP_IN_PATH classpath)
>> >> > ---
>> >> >>    HADOOP_CLASSPATH=$($HADOOP_IN_PATH classpath 2>/dev/null)
>> >> > 123c123
>> >> > <         java.library.path)
>> >> > ---
>> >> >>        java.library.path 2>/dev/null)
>> >> > 142c142
>> >> > <     HBASE_CLASSPATH=$($HBASE_IN_PATH classpath)
>> >> > ---
>> >> >>    HBASE_CLASSPATH=$($HBASE_IN_PATH classpath 2>/dev/null)
>> >> >
>> >> >
>> >> > Regards,
>> >> >
>> >> > Dano
>> >>
>> >> --
>> >> Alexander Alten-Lorenz
>> >> http://mapredit.blogspot.com
>> >> German Hadoop LinkedIn Group: http://goo.gl/N8pCF
>> >>
>> >
>>
>>
>>
>> --
>> Apache MRUnit - Unit testing MapReduce -
>> http://incubator.apache.org/mrunit/
>
>

--
Apache MRUnit - Unit testing MapReduce - http://incubator.apache.org/mrunit/