Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop >> mail # dev >> commons-configuration parsing error with ivy


Copy link to this message
-
Re: commons-configuration parsing error with ivy
Chris had the exact the same problem and we discovered the same
reason/solution (ivy-2.0.0rc2.jar in $HOME/.ant/lib) by turning on ant
debug (ant -d -v). I didn't know that it's a prevalent issue though.

On Tue, May 24, 2011 at 10:50 PM, Todd Lipcon <[EMAIL PROTECTED]> wrote:
> Hey folks,
>
> I've seen this error pop up on various people's build environments
> before, and never been able to find a good explanation:
>
> ivy-resolve-common:
> [ivy:resolve]
> [ivy:resolve] :: problems summary ::
> [ivy:resolve] :::: WARNINGS
> [ivy:resolve]   io problem while parsing ivy file:
> http://repo1.maven.org/maven2/commons-configuration/commons-configuration/1.6/commons-configuration-1.6.pom:
> Resetting to invalid mark
> [ivy:resolve]           module not found:
> commons-configuration#commons-configuration;1.6
> [ivy:resolve]   ==== apache-snapshot: tried
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/commons-configuration/commons-configuration/1.6/commons-configuration-1.6.pom
> [ivy:resolve]     -- artifact
> commons-configuration#commons-configuration;1.6!commons-configuration.jar:
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/commons-configuration/commons-configuration/1.6/commons-configuration-1.6.jar
> [ivy:resolve]   ==== maven2: tried
> [ivy:resolve]
> http://repo1.maven.org/maven2/commons-configuration/commons-configuration/1.6/commons-configuration-1.6.pom
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           ::
> commons-configuration#commons-configuration;1.6: not found
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]
> [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
>
>
> In case anyone else runs into this issue, here's the solution: it
> turns out I had a copy of ivy 2.0.0rc2 in $HOME/.ant/lib. This was
> taking precedence over the ivy 2.1.0 that Hadoop itself downloads. I'm
> not sure how it got there, but after removing it from ~/.ant, the
> build works fine.
>
> Hopefully this will end up in Google's magical index and save people
> some minutes down the line.
>
> -Todd
> --
> Todd Lipcon
> Software Engineer, Cloudera
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB