Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop >> mail # user >> HBase MasterNotRunningException


Copy link to this message
-
Re: HBase MasterNotRunningException
Hi,

I am getting the pages when requested below URLs from remote boxes for
master and region server.

http://192.265.47.222:60010/master-status

http://192.265.47.222:60030/rs-status

What is DNS configuration file, where can I find these files to modify. I
do not have much knowledge on DNS and networking files etc.

Coming to DNS name instead of IP address, I need to modify all the conf
files from Hadoop and HBase along with /etc/hosts file. Please let me know
if I need to modify some more files also.
Thank You,
Jilani

On Fri, Aug 31, 2012 at 4:26 AM, anil gupta <[EMAIL PROTECTED]> wrote:

> Sorry, I messed up my last email. Please ignore that.
>
> In addition to Stack's suggestion, use DNS names instead of IP address in
> configuration of Hadoop and HBase. Its a bad idea to use IP address in
> configuration of Hadoop/HBase. Check your DNS configuration file also.
> By sudo i meant that run the netstat command like this: "sudo netstat
> -alnp" . "sudo" is used to run a command with root privileges.
>
> ~Anil
>
> On Thu, Aug 30, 2012 at 3:54 PM, anil gupta <[EMAIL PROTECTED]> wrote:
>
> > In addition to Stack's suggestion, use DNS names instead of IP address in
> > configuration of Hadoop and HBase. Its a bad idea to use DNS names in
> > configuration. Check your DNS configuration file.
> >
> > By sudo i meant that run the netstat command like this: "sudo netstat
> > -alnp" . "sudo" is used to run a command with root privileges.
> >
> > ~Anil
> >
> >
> > On Thu, Aug 30, 2012 at 3:40 PM, Stack <[EMAIL PROTECTED]> wrote:
> >
> >> On Thu, Aug 30, 2012 at 12:17 PM, Jilani Shaik <[EMAIL PROTECTED]>
> >> wrote:
> >> > telnet is working for 60010, 60030 and 9000 from both the local and
> >> remote
> >> > boxes.
> >> >
> >>
> >> Then the hbase daemons are not running or as Anil is suggesting, the
> >> connectivity between machines needs fixing (It looks like all binds to
> >> localhost.. can you fix that?).  Once your connectivity fixed, then
> >> try running HBase.
> >>
> >> St.Ack
> >>
> >
> >
> >
> > --
> > Thanks & Regards,
> > Anil Gupta
> >
>
>
>
> --
> Thanks & Regards,
> Anil Gupta
>