Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> LoadTestTool and PerformanceEvaluation not working from Hbase installation


+
ramkrishna vasudevan 2013-10-08, 17:10
+
Ted Yu 2013-10-08, 17:14
Copy link to this message
-
Re: LoadTestTool and PerformanceEvaluation not working from Hbase installation
./hbase org.apache.hadoop.hbase.PerformanceEvaluation sequentialWrite 1
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/hadoop/hbase/PerformanceEvaluation
Caused by: java.lang.ClassNotFoundException:
org.apache.hadoop.hbase.PerformanceEvaluation
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Could not find the main class:
org.apache.hadoop.hbase.PerformanceEvaluation.  Program will exit.

This is the way I had been using for sometime now.
On Tue, Oct 8, 2013 at 10:44 PM, Ted Yu <[EMAIL PROTECTED]> wrote:

> Can you give us the whole stack trace ?
>
> What command did you use ?
>
> Thanks
>
>
> On Tue, Oct 8, 2013 at 10:10 AM, ramkrishna vasudevan <
> [EMAIL PROTECTED]> wrote:
>
> > Hi
> > I downloaded the trunk code.. Compiled the code..
> > Trying to run LoadTestTool and PerfEvlautionTool.  I get
> > ClassNotFoundException.  Has anything changed in the class path settings?
> >
> > Regards
> > Ram
> >
>
+
Ted Yu 2013-10-08, 18:30
+
ramkrishna vasudevan 2013-10-09, 04:54