Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # dev >> [UPDATE] Upgrade to protobuf 2.5.0 for the 2.1.0 release, HADOOP-9845


Copy link to this message
-
Re: [UPDATE] Upgrade to protobuf 2.5.0 for the 2.1.0 release, HADOOP-9845
There is no indication that protoc 2.5.0 is breaking anything.

Hadoop-trunk builds have been failing way before 1/2 way with:

-------
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-surefire-plugin:2.12.3:test
(default-test) on project hadoop-yarn-client: ExecutionException;
nested exception is java.util.concurrent.ExecutionException:
java.lang.RuntimeException: The forked VM terminated without saying
properly goodbye. VM crash or System.exit called ? -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to
execute goal org.apache.maven.plugins:maven-surefire-plugin:2.12.3:test
(default-test) on project hadoop-yarn-client: ExecutionException;
nested exception is java.util.concurrent.ExecutionException:
java.lang.RuntimeException: The forked VM terminated without saying
properly goodbye. VM crash or System.exit called ?

-------
The Hadoop-trunk #480 build failed with a JVM abort in a testcase towards
the end of mapreduce tests.

Until then there were no failures at all.

I've increased heap size and tried a second run and the failure was earlier.

I've looked a Hadoop-trunk builds prior to the HADOOP-9845 and it has been
failing the same way in all the kept builds.

We need to fix Hadoop-trunk builds independently of this.

Any objection to commit HADOOP-9845 to branch-2 and the 2.1.0-beta branches
to get all the other jenkins jobs working?

I'll wait till tomorrow morning before proceeding.

Thx
On Mon, Aug 12, 2013 at 8:35 PM, Alejandro Abdelnur <[EMAIL PROTECTED]>wrote:

> Jenkins is running a full test run on trunk using protoc 2.5.0.
>
>   https://builds.apache.org/job/Hadoop-trunk/480
>
> And it seems go be going just fine.
>
> If everything looks OK, I'm planing to backport HADOOP-9845 to the
> 2.1.0-beta branch midday PST tomorrow. This will normalize all builds
> failures do the protoc mismatch.
>
> Thanks.
>
> Alejandro
>
>
> On Mon, Aug 12, 2013 at 5:53 PM, Alejandro Abdelnur <[EMAIL PROTECTED]>wrote:
>
>> shooting to get it i n for 2.1.0.
>>
>> at moment is in trunk till the nightly finishes. then we'll decide
>>
>> in the mean time, you can have multiple versions installed in diff dirs
>> and set the right one in the path
>>
>> thx
>>
>> Alejandro
>> (phone typing)
>>
>> On Aug 12, 2013, at 17:47, Konstantin Shvachko <[EMAIL PROTECTED]>
>> wrote:
>>
>> > Ok. After installing protobuf 2.5.0 I can compile trunk.
>> > But now I cannot compile Hadoop-2 branches. None of them.
>> > So if I switch between branches I need to reinstall protobuf?
>> >
>> > Is there a consensus about going towards protobuf 2.5.0 upgrade in ALL
>> > versions?
>> > I did not get definite impression there is.
>> > If not it could be a pretty big disruption.
>> >
>> > Thanks,
>> > --Konst
>> >
>> >
>> >
>> > On Mon, Aug 12, 2013 at 3:19 PM, Alejandro Abdelnur <[EMAIL PROTECTED]
>> >wrote:
>> >
>> >> I've just committed HADOOP-9845 to trunk (only trunk at the moment).
>> >>
>> >> To build trunk now you need protoc 2.5.0 (the build will fail with a
>> >> warning if you don't have it).
>> >>
>> >> We'd propagate this to the 2 branches once the precommit build is back
>> to
>> >> normal and see things are OK.
>> >>
>> >> Thanks.
>> >>
>> >>
>> >> On Mon, Aug 12, 2013 at 2:57 PM, Alejandro Abdelnur <[EMAIL PROTECTED]
>> >>> wrote:
>> >>
>> >>> About to commit HADOOP-9845 to trunk, in 5 mins. This will make trunk
>> use
>> >>> protoc 2.5.0.
>> >>>
>> >>> thx
>> >>>
>> >>>
>> >>> On Mon, Aug 12, 2013 at 11:47 AM, Giridharan Kesavan <
>> >>> [EMAIL PROTECTED]> wrote:
>> >>>
>> >>>> I can take care of re-installing 2.4 and installing 2.5 in a
>> different
>> >>>> location. This would fix 2.0 branch builds as well.
>> >>>> Thoughts?
>> >>>>
>> >>>> -Giri
>> >>>>
>> >>>>
>> >>>> On Mon, Aug 12, 2013 at 11:37 AM, Alejandro Abdelnur <
>> [EMAIL PROTECTED]
>> >>>>> wrote:
>> >>>>
>> >>>>> Giri,
>> >>>>>
>> >>>>> first of all, thanks for installing protoc 2.5.0.
>> >>>>>
>> >>>>> I didn't know we were installing them as the only version and not

Alejandro
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB