Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HDFS >> mail # user >> error copying file from local to hadoop fs


Copy link to this message
-
Re: error copying file from local to hadoop fs
But in standalone mode, should the safemode be faster? I mean because
everything is running locally. still the deamons are not visible in jps.
how can i restart it individually?

also, the service status returned this info:

Hadoop namenode is running                                 [  OK  ]
Hadoop secondarynamenode is not running                    [FAILED]

Is the secondary namenode, not supposed to run in standalone mode? i am not
able to restart this service also.. it just gives unrecognized service.
On Fri, Mar 29, 2013 at 1:00 PM, Anand Aravindan
<[EMAIL PROTECTED]>wrote:

>  Hello,
> In the Safe Mode, -copyFromLocal would not work.
> Please read:
> http://hadoop.apache.org/docs/stable/hdfs_user_guide.html#Safemode
>
> Please wait a bit for the HDFS system to exit SafeMode. If it takes a
> significantly long time, and the HDFS is still in the SafeMode, something
> could be wrong with your HDFS setup.
>
>
>
> On Fri, Mar 29, 2013 at 12:20 AM, Ravi Chandran <[EMAIL PROTECTED]
> > wrote:
>
>> Thanks for replying, I did jps, it doesnt show any of the deamon
>> services.  also, i just got the error message showing:
>>
>>  Cannot create file/user/training/inputs/basic.txt._COPYING_. Name node
>> is in safe mode.
>>
>> looks like JT and DN are not responding to NN. but this is a standalone
>> setup, i dont understand how it can have communication issue.
>>
>>  On Fri, Mar 29, 2013 at 12:46 PM, Jagat Singh <[EMAIL PROTECTED]>wrote:
>>
>>> Your cluster is not running properly.
>>>
>>> Can you do jps and see if all services are running.
>>>
>>> JT
>>> NN
>>> DN
>>>
>>> etc
>>>
>>>
>>>
>>>
>>> On Fri, Mar 29, 2013 at 6:07 PM, Ravi Chandran <
>>> [EMAIL PROTECTED]> wrote:
>>>
>>>> hi,
>>>> I am trying to copy a local text file into hadoop fs using
>>>> -copyFromLocal option, but i am getting error:
>>>>
>>>>  13/03/29 03:02:54 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 0 time(s); maxRetries=45
>>>> 13/03/29 03:03:15 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 1 time(s); maxRetries=45
>>>> 13/03/29 03:03:36 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 2 time(s); maxRetries=45
>>>> 13/03/29 03:03:57 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 3 time(s); maxRetries=45
>>>> 13/03/29 03:04:18 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 4 time(s); maxRetries=45
>>>> 13/03/29 03:04:39 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 5 time(s); maxRetries=45
>>>> 13/03/29 03:05:00 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 6 time(s); maxRetries=45
>>>> 13/03/29 03:05:21 INFO ipc.Client: Retrying connect to server:
>>>> 0.0.0.0/0.0.0.0:8020. Already tried 7 time(s); maxRetries=45
>>>>
>>>> I have checked the services, they seem to be running. what should i do
>>>> now?
>>>>
>>>> --
>>>> Thanks & Regards
>>>> Ravi
>>>>
>>>
>>>
>>
>>
>> --
>> Thanks & Regards
>> Ravi
>>
>
>
>
> --
> *Live Long and Prosper !*
>

--
Thanks & Regards
Ravi