Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive >> mail # dev >> Phabricator issues, libphutil v1 libraries are no longer supported


Copy link to this message
-
Phabricator issues, libphutil v1 libraries are no longer supported
I've been having issues using Phabricator to create a patch for hive. It looks like some versioning issues with arc_jira_lib and libphutil.
I kept getting this error: "libphutil v1 libraries are no longer supported."
To work around it go to the libphutil directory you checked out of git and revert to an older commit:
git checkout 870bcc76434410344d27a3fa4604ac96200bf7f6

The next problem is the arc client:
ERR-BAD-VERSION: Your 'arc' client version is '6', which is newer than the server version, '5'. Upgrade your Phabricator install.
So also get an older version:
git checkout 6cb8d483b23c132da4c82934438cd1af0e5ba32b

I'll leave the actual fixing to someone with a bit more php experience.

After that I tried to "arc diff HIVE-3308" added the message then:
Linting...
LINT OKAY  No lint problems.
Running unit tests...
No unit test engine is configured for this project.
Usage Exception: There are no changes to generate a diff from!

In the end I manually uploaded It as D8187. And added the patch to Jira even tough I guess that's what arc is suppose to do.

Bennie.

NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB