Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Hive >> mail # dev >> Re: [jira] [Updated] (HIVE-2715) Upgrade Thrift dependency to 0.9.0


Copy link to this message
-
Re: [jira] [Updated] (HIVE-2715) Upgrade Thrift dependency to 0.9.0
Hi Ashutosh,

Thank you for working on it.

After upgrade, is this still the command to build thrift "ant thriftif
-Dthrift.home=/usr/local"

I upgrade my thrift to 0.9.0. I see the following files generated and not
in version control:

metastore/src/gen/thrift/gen-javabean/org/apache/hadoop/hive/metastore/api/
Constants.java
serde/src/gen/thrift/gen-javabean/org/apache/hadoop/hive/serde/Constants.ja
va

Thanks

Tim

On 11/8/12 1:54 AM, "Ashutosh Chauhan (JIRA)" <[EMAIL PROTECTED]> wrote:

>
>     [
>https://issues.apache.org/jira/browse/HIVE-2715?page=com.atlassian.jira.pl
>ugin.system.issuetabpanels:all-tabpanel ]
>
>Ashutosh Chauhan updated HIVE-2715:
>-----------------------------------
>
>       Resolution: Fixed
>    Fix Version/s: 0.10.0
>           Status: Resolved  (was: Patch Available)
>
>Committed to trunk.
>                
>> Upgrade Thrift dependency to 0.9.0
>> ----------------------------------
>>
>>                 Key: HIVE-2715
>>                 URL: https://issues.apache.org/jira/browse/HIVE-2715
>>             Project: Hive
>>          Issue Type: Bug
>>          Components: Metastore
>>    Affects Versions: 0.8.0, 0.9.0
>>            Reporter: Mithun Radhakrishnan
>>            Assignee: Ashutosh Chauhan
>>             Fix For: 0.10.0
>>
>>         Attachments: hive-2715_2.patch, hive-2715.patch
>>
>>
>> I work on HCatalog (0.2). Recently, we ran into HCat_server running out
>>of memory every few days, and it boiled down to a bug in thrift,
>>(THRIFT-1468, recently fixed).
>> HCat-0.2-branch depends on Hive-0.8, which in turn depends on
>>thrift-0.5.0. (The bug also exists on 0.7.0.)
>> May I please enquire if Hive can't depend on a more current version of
>>thrift? (Does it break the metastore?) I'm afraid I'm not privy to the
>>reasoning behind Hive's dependency on a slightly dated thrift-lib.
>
>--
>This message is automatically generated by JIRA.
>If you think it was sent incorrectly, please contact your JIRA
>administrators
>For more information on JIRA, see: http://www.atlassian.com/software/jira
+
Ashutosh Chauhan 2012-11-08, 16:21
+
Gang Tim Liu 2012-11-08, 23:11
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB