Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - AssignmentManager looping?


Copy link to this message
-
Re: AssignmentManager looping?
Jimmy Xiang 2013-08-01, 18:29
It will be great if you can reproduce this issue.  One thing to keep in
mind is not to run hbck(repair) in this case since hbck may have some
problem to handle the split parent properly.

By the way, in trunk, region split uses multi row mutate to update meta,
which is more reliable.  So I think the issue should have been fixed in
trunk.
On Thu, Aug 1, 2013 at 11:07 AM, Jean-Marc Spaggiari <
[EMAIL PROTECTED]> wrote:

> No,it's a HBase 0.94.10 cluster with Hadoop 1.0.3, everything installed
> manually from JARs ;) It's a mess to monitor and I would have loved to have
> it under CM now, but I have to deal with that ;)
>
> I'm building a 2nd cluster at home so I will be able to replicate this one
> to the other one, which might allow me to play even further with it...
>
> I will try to reproduce the issue, give me just couple of hours...
>
> JM
>
> 2013/8/1 Kevin O'dell <[EMAIL PROTECTED]>
>
> > Jimmy,
> >
> >   Sounds like our dreaded reference file issue again. I spoke with JM and
> > he is going to try to reproduce this  My gut tells me our point of no
> > return may be in the wrong place due to some code change along the way,
> but
> > hbck could also just be doing something wonky.
> >
> > JM,
> >
> >   This cluster is not CM managed correct?
> > On Aug 1, 2013 1:49 PM, "Jean-Marc Spaggiari" <[EMAIL PROTECTED]>
> > wrote:
> >
> > > So I had to remove few reference files and run few hbck to get
> everything
> > > back online.
> > >
> > > Summary: don't stop your cluster while it's major compacting huge
> tables
> > ;)
> > >
> > > Thanks all!
> > >
> > > JM
> > >
> > > 2013/8/1 Kevin O'dell <[EMAIL PROTECTED]>
> > >
> > > > If that doesn't work you probably have an invalid reference file and
> > you
> > > > will find that in RS logs for the HLog split that is never finishing.
> > > > On Aug 1, 2013 1:38 PM, "Kevin O'dell" <[EMAIL PROTECTED]>
> > wrote:
> > > >
> > > > > JM,
> > > > >
> > > > > Stop HBase
> > > > > rmr /hbase from zkcli
> > > > > Sideline META
> > > > > Run offline meta repair
> > > > > Start HBase
> > > > > On Aug 1, 2013 1:01 PM, "Jean-Marc Spaggiari" <
> > [EMAIL PROTECTED]
> > > >
> > > > > wrote:
> > > > >
> > > > >> Hi Jimmy,
> > > > >>
> > > > >> I should still have all the logs.
> > > > >>
> > > > >> What I did is pretty simple.
> > > > >>
> > > > >> I tried to turn the cluster off while a single regioned 250GB
> table
> > > was
> > > > >> under major_compaction to get splitted.
> > > > >>
> > > > >> I will targz all the logs for the few last days and make that
> > > available.
> > > > >>
> > > > >> On the other side, I'm still not able to bring it back up...
> > > > >>
> > > > >> JM
> > > > >>
> > > > >> 2013/8/1 Jimmy Xiang <[EMAIL PROTECTED]>
> > > > >>
> > > > >> > Something went wrong with split.  It should be easy to fix your
> > > > cluster.
> > > > >> > However, it will be more interesting to find out how it
> happened.
> > Do
> > > > you
> > > > >> > remember what has happened since it was good previously? Do you
> > have
> > > > all
> > > > >> > the logs?
> > > > >> >
> > > > >> >
> > > > >> > On Thu, Aug 1, 2013 at 7:08 AM, Jean-Marc Spaggiari <
> > > > >> > [EMAIL PROTECTED]
> > > > >> > > wrote:
> > > > >> >
> > > > >> > > I tried to remove the znodes but got the same result. So I
> > shutted
> > > > >> down
> > > > >> > all
> > > > >> > > the RS and restarted HBase, and now I have 0 regions for this
> > > table.
> > > > >> > > Running HBCK. Seems that it has a lot to do...
> > > > >> > >
> > > > >> > > 2013/8/1 Kevin O'dell <[EMAIL PROTECTED]>
> > > > >> > >
> > > > >> > > > Yes you can if HBase is down, first I would copy .META out
> of
> > > HDFS
> > > > >> > local
> > > > >> > > > and then you can search it for split issues. Deleting those
> > > znodes
> > > > >> > should
> > > > >> > > > clear this up though.
> > > > >> > > > On Aug 1, 2013 8:52 AM, "Jean-Marc Spaggiari" <
> > > > >> [EMAIL PROTECTED]
> > > > >> > >
> > > >