Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo, mail # user - Waiting for accumulo to be initialized


+
Aji Janis 2013-03-27, 14:10
+
Eric Newton 2013-03-27, 14:27
+
Aji Janis 2013-03-27, 14:29
+
Eric Newton 2013-03-27, 14:44
+
Aji Janis 2013-03-27, 14:47
+
Eric Newton 2013-03-27, 14:52
+
Aji Janis 2013-03-27, 15:20
+
Eric Newton 2013-03-27, 15:23
+
Aji Janis 2013-03-27, 15:31
+
Josh Elser 2013-03-27, 15:50
+
Aji Janis 2013-03-27, 19:18
+
Eric Newton 2013-03-27, 19:33
+
Aji Janis 2013-03-27, 19:39
+
Eric Newton 2013-03-27, 20:19
+
Aji Janis 2013-03-27, 20:45
+
Krishmin Rai 2013-03-27, 21:00
+
Aji Janis 2013-03-28, 12:56
Copy link to this message
-
Re: Waiting for accumulo to be initialized
Josh Elser 2013-03-27, 19:40
First off, I'm sorry about you losing data. I thought you recognized
that this would be destructive on your data reading that link you sent
out. I wasn't really advising you from a "saving data" standpoint.

Zookeeper crashing (or even `kill -9`ing) should have no effect on
Hadoop. Did Hadoop come up correctly before you tried to restart
Accumulo? Did you then do the `hadoop namenode -format` and expect to
keep your data? If so, lesson learned?
On 3/27/13 3:18 PM, Aji Janis wrote:
> Eric and Josh thanks for all your feedback. We ended up _loosing all
> our accumulo data_ because I had to reformat hadoop. Here is in a
> nutshell what I did:
>
>  1. Stop accumulo
>  2. Stop hadoop
>  3. On hadoop master and all datanodes, from dfs.data.dir
>     (hdfs-site.xml) remove everything under the data folder
>  4. On hadoop master, from dfs.name.dir (hdfs-site.xml) remove
>     everything under the name folder
>  5. As hadoop user, execute.../hadoop/bin/hadoop namenode -format
>  6. As hadoop user, execute.../hadoop/bin/start-all.sh ==> should
>     populate data/ and name/ dirs that was erased in steps 3, 4.
>  7. Initialized Accumulo - as accumulo user,  ../accumulo/bin/accumulo
>     init (I created a new instance)
>  8. Start accumulo
>
> I was wondering if anyone had suggestions or thoughts on how I could
> have solved the original issue of accumulo waiting initialization
> without loosing my accumulo data? Is it possible to do so?

+
Aji Janis 2013-03-27, 19:56
+
Aji Janis 2013-03-27, 15:48