Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase, mail # user - how config multi regionserver, or what is wrong?


+
tgh 2012-12-10, 09:48
+
Nick Dimiduk 2012-12-11, 02:36
+
Jean-Marc Spaggiari 2012-12-10, 12:54
Copy link to this message
-
答复: how config multi regionserver, or what is wrong?
tgh 2012-12-11, 01:00
Thank you for your reply,
And the configuration file is here,
Could you help me,
Thank you
---------------------------
Tian Guanhua

[root@blade1 conf]# cat regionservers
blade1
blade2
blade3
blade4
blade5
blade6
blade7
blade8
[root@blade1 conf]#
[root@blade1 conf]# vim hbase-site.xml
<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="configuration.xsl"?>
<!--
-->
<configuration>
<property>
    <name>hbase.rootdir</name>
    <value>hdfs://blade1:9000/hbase</value>
    <description>The directory shared by RegionServers.</description>
</property>
<property>
    <name>hbase.cluster.distributed</name>
    <value>true</value>
</property>
<property>
    <name>hbase.zookeeper.quorum</name>
    <value>blade1,blade2,blade3</value>
</property>
 <property>
    <name>hbase.zookeeper.property.dataDir</name>
   <value>/home/liuxin/zookeeper/data</value>
 </property>
 <property>
  <name>dfs.support.append</name>
   <value>true</value>
 </property>
 <property>
  <name>dfs.datanode.max.xcievers</name>
   <value>4096</value>
   </property>
 <property>
 <name>hbase.master</name>
 <value>blade1:60000</value>
 </property>
</configuration>
-----邮件原件-----
发件人: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] 代表 Jean-Marc Spaggiari
发送时间: 2012年12月10日 20:54
收件人: [EMAIL PROTECTED]
主题: Re: how config multi regionserver, or what is wrong?

Hi Tian,

Can you share you configuration files?

Do you have something like that on your hbase-site.xml file?

  <property>
    <name>hbase.cluster.distributed</name>
    <value>true</value>
    <description>The mode the cluster will be in. Possible values are
      false: standalone and pseudo-distributed setups with managed Zookeeper
      true: fully-distributed with unmanaged Zookeeper Quorum (see hbase-env.sh)
    </description>
  </property>
JM

2012/12/10, tgh <[EMAIL PROTECTED]>:
> Hi
> I try to use hbase, and now ,I have a problem with hbase
> configuration, I use 8node for try, and it seems to work, hadoop,
> zookeeper, hbase all boot up, and it could insert into with putAPI ,
> But when I try to use masterIP:60010 to manage it, I find there are
> only one regionserver there, and it is localhost:60030, why?
> I have set regionserver file , there are 8 nodes there, and all could
> ssh to each other without passwd,
>
> And I also use hdfsNamenodeIP:50070 to see HDFS, and it seems OK, the
> data have been balanced across 8node, but I wander hbase only have one
> regionserver to work, although when I star/stop regionserver , there
> are 8region server to start and stop,
>
> And I try to put data into hbase, it seems ok at first, but after
> 200million in hbase, it seems really hard to insert more into it, it
> is very slow, and I use masterIP:60010 to manage it, I find there are
> only one regionserver there, and it is localhost:60030, why?
>
>
> Could you help me,
>
>
>
> Thank you
> -------------------
> Tian Guanhua
>
>
>
>
>
>
>
+
tgh 2012-12-11, 01:59
+
tgh 2012-12-11, 02:17
+
Leonid Fedotov 2012-12-11, 07:28