Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase, mail # user - RS not processing any requests


+
Nathaniel Cook 2012-09-05, 21:58
+
Stack 2012-09-05, 22:39
+
Jeff Whiting 2012-09-05, 22:51
Copy link to this message
-
Re: RS not processing any requests
Himanshu Vashishtha 2012-09-05, 22:47
Your RS priority handlers are blocked on meta lookup, so it becomes
unresponsive. Looks like you hitting
https://issues.apache.org/jira/browse/HBASE-6165
You running HBase replication? just confirming.

Himanshu

On Wed, Sep 5, 2012 at 4:39 PM, Stack <[EMAIL PROTECTED]> wrote:
> On Wed, Sep 5, 2012 at 2:58 PM, Nathaniel Cook <[EMAIL PROTECTED]> wrote:
>> We ran a jstack on the both the RS process and the hbase shell process
>> trying to do the scan.
>>
>> Jstack log for RS:
>> http://pastebin.com/9Y9t5ERE
>>
>
>
> What JVM (I don't know what (20.10-b01 mixed mode) is).
>
> I see a bunch of this:
>
> "PRI IPC Server handler 5 on 60020" daemon prio=10
> tid=0x00002aaac10a1800 nid=0x92f waiting for monitor entry
> [0x000000004ab0f000]
>    java.lang.Thread.State: BLOCKED (on object monitor)
>         at .....
>
> But when I go to look for other instances of the object monitor, I
> don't find any.  I see this for each instance of BLOCKED (Or at least,
> the two or three I checked).
>
> Whats your OS?
>
> St.Ack
+
Jeff Whiting 2012-09-05, 23:18
+
Himanshu Vashishtha 2012-09-05, 23:23
+
Jeff Whiting 2012-09-05, 23:53
+
Himanshu Vashishtha 2012-09-06, 00:09
+
Ted Yu 2012-09-06, 00:49
+
Jeff Whiting 2012-09-06, 15:04
+
Jeff Whiting 2012-09-06, 15:04
+
Jeff Whiting 2012-09-05, 22:51