Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Drill >> mail # dev >> Trying to get started....


Copy link to this message
-
Re: Trying to get started....
You actually need 2.5.x, not 2.4.x.  The compile errors are due to that.

J
On Jun 30, 2013 1:36 AM, "Azuryy Yu" <[EMAIL PROTECTED]> wrote:

> and you'd better install protobuf-2.4.x,  not 2.5!
>
> --Send from my Sony mobile.
> On Jun 30, 2013 2:49 PM, "Philip Haynes" <
> [EMAIL PROTECTED]>
> wrote:
>
> > Srihari -
> >
> > > java.io.IOException: *Cannot run program "protoc" (in directory
> >
> >
> > Maven is telling you that you need to install protocol buffers which you
> > can find here
> > http://code.google.com/p/protobuf/
> >
> > On 30/06/13 4:44 PM, "Srihari Srinivasan" <[EMAIL PROTECTED]>
> > wrote:
> >
> > >When I try to do mvn install on the execwork branch this is the error I
> > >get
> > >-
> > >
> > >[ERROR] Failed to execute goal
> > >org.apache.maven.plugins:maven-antrun-plugin:1.6:run (generate-sources)
> on
> > >project java-exec: An Ant BuildException has occured: Execute failed:
> > >java.io.IOException: *Cannot run program "protoc" (in directory
> >
> >"/Users/ssriniva/projects/personal/incubator-drill/sandbox/prototype/exec/
> > >java-exec"):
> > >error=2, No such file or directory -> [Help 1]*
> > >org.apache.maven.lifecycle.LifecycleExecutionException: Failed to
> execute
> > >goal org.apache.maven.plugins:maven-antrun-plugin:1.6:run
> > >(generate-sources) on project java-exec: An Ant BuildException has
> > >occured:
> > >Execute failed: java.io.IOException: Cannot run program "protoc" (in
> > >directory
> >
> >"/Users/ssriniva/projects/personal/incubator-drill/sandbox/prototype/exec/
> > >java-exec"):
> > >error=2, No such file or directory
> > >
> > >Help!
> > >
> > >-- Hari
> > >
> > >On Sun, Jun 30, 2013 at 3:08 AM, Timothy Chen <[EMAIL PROTECTED]>
> wrote:
> > >
> > >> Hi Srihari,
> > >>
> > >> Yes the execwork branch is the place to start off if you're working
> with
> > >> the DrillBits.
> > >>
> > >> Latest master is already merged in that branch so the
> > >>ReferenceInterpreter
> > >> also works too.
> > >>
> > >> Let us know if you encounter any problems.
> > >>
> > >> Tim
> > >>
> > >>
> > >> On Sat, Jun 29, 2013 at 2:17 PM, Srihari Srinivasan <
> > >> [EMAIL PROTECTED]> wrote:
> > >>
> > >> > Hi Folks,
> > >> >
> > >> > I am trying to get started with the REST APIs. I've forked the
> > >>codebase
> > >> > using my github account and merged my local copy with the upstream
> > >> > "execwork" branch. I am doing this because the sources for Drillbit
> > >>and
> > >> > related classes seem to be in the execwork branch currently. I'll
> > >>need to
> > >> > work with them as part of this feature.
> > >> >
> > >> > Is my approach so far correct? Can I expect mvn install on the
> > >> > ReferenceInterpreter to work fine after these steps?
> > >> >
> > >> > Hari
> > >> >
> > >>
> >
> >
> >
>