Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Zookeeper >> mail # user >> Dynamically Adding nodes to ZK Ensemble


+
Russ Lavoy 2013-08-13, 19:49
+
Deepak Jagtap 2013-08-13, 22:42
+
Alexander Shraer 2013-08-13, 22:46
+
Deepak Jagtap 2013-08-14, 17:20
+
Alexander Shraer 2013-08-14, 17:31
+
Deepak Jagtap 2013-08-20, 01:40
+
Alexander Shraer 2013-08-20, 01:51
+
Russ Lavoie 2013-08-15, 12:12
+
Flavio Junqueira 2013-08-15, 13:07
+
Flavio Junqueira 2013-08-15, 14:13
+
Russ Lavoie 2013-08-15, 19:27
+
Jordan Zimmerman 2013-08-15, 19:43
+
Russ Lavoie 2013-08-15, 20:44
Copy link to this message
-
Re: Dynamically Adding nodes to ZK Ensemble
Please post any issues you're having with Exhibitor on the Github site.

> I add a new zookeeper via the UI in exhibitor. It disappears from the UI
How do you have the shared configuration set? Is it S3? Shared file? Are there any errors in the log?

> The REST API is not working for me either.  Gives me invalid method even though I have nodemodification set to true…  
There was a bug with this. Make sure you have the latest version.

-JZ

On Aug 15, 2013, at 1:44 PM, Russ Lavoie <[EMAIL PROTECTED]> wrote:

> Jordan,
>
> We are trying to use exhibitor...  It is

> not working as I expect it to. I read through the docs (maybe I missed something) and I am not sure how I can do this.
>
> I add a new zookeeper via the UI in exhibitor.  It turns green and seems happy, then moments later... It disappears from the UI.  But if I manually add it into the "com.netflix.exhibitor-rolling.servers-spec" and "com.netflix.exhibitor.servers-spec"
>
> The REST API is not working for me either.  Gives me invalid method even though I have nodemodification set to true...  
>
> Any help on this would be fantastic!
>
> Thanks
>
>
> ________________________________
> From: Jordan Zimmerman <[EMAIL PROTECTED]>
> To: [EMAIL PROTECTED]
> Sent: Thursday, August 15, 2013 2:43 PM
> Subject: Re: Dynamically Adding nodes to ZK Ensemble
>
>
> There's no way (other than manual config change) that I know of. It's why I wrote Exhibitor: https://github.com/Netflix/exhibitor
>
> -JZ
>
> On Aug 15, 2013, at 12:27 PM, Russ Lavoie <[EMAIL PROTECTED]> wrote:
>
>> The main reason why I ask, is because I need the ability to dynamically add ZK nodes to the ensemble.  Is there a supported way to do this in 3.4.5?
>>
>> Thanks,
>>
>> Russ
>>
>>
>> ________________________________
>> From: Flavio Junqueira <[EMAIL PROTECTED]>
>> To: [EMAIL PROTECTED]
>> Cc: Russ Lavoy <[EMAIL PROTECTED]>
>> Sent: Thursday, August 15, 2013 9:13 AM
>> Subject: Re: Dynamically Adding nodes to ZK Ensemble
>>
>>
>> Hopefully it is clear that I tried to say long, not log lists.  :-)
>>
>> -Flavio
>>
>> On Aug 15, 2013, at 3:07 PM, Flavio Junqueira <[EMAIL PROTECTED]> wrote:
>>
>>> There are log lists of patches available and issues for 3.5.0. There are only 7 blockers currently marked, though. Until we decide what to do with all those, we won't have a release. The bottom line is that we don't have a date, even though the general feeling is that we would like to have it soon. The are important features lined up for 3.5.0. It viable to have 3.4.6 shortly, though.
>>>
>>> -Flavio
>>>
>>>
>>> On Aug 14, 2013, at 12:42 AM, Deepak Jagtap <[EMAIL PROTECTED]> wrote:
>>>
>>>> Hi Russ,
>>>>
>>>> This presentation gives brief idea about zookeeper cluster reconfig
>>>> mechanism:
>>>> http://www.slideshare.net/Hadoop_Summit/dynamic-reconfiguration-of-zookeeper
>>>>
>>>> zookeeper 3.5.0 source has zkCli.sh utility which supports reconfig command
>>>> to
>>>> dynamically reconfigure the cluster.
>>>>
>>>> Regards,
>>>> Deepak
>>>>
>>>>
>>>>
>>>>
>>>> On Tue, Aug 13, 2013 at 12:49 PM, Russ Lavoy <[EMAIL PROTECTED]> wrote:
>>>>
>>>>> Hello,
>>>>>
>>>>> I would like to add ZK nodes dynamically to an ensemble.  I have seen
>>>>> https://issues.apache.org/jira/browse/ZOOKEEPER-107 but I do not see any
>>>>> documentation on how to do this.
>>>>>
>>>>> Can anyone give me some insight?
>>>>>
>>>>> Thanks