Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Using thrift2 interface but getting : 400 Bad Request


Copy link to this message
-
Re: Using thrift2 interface but getting : 400 Bad Request
No logs there either (in fact no logs are written in any log file when I
execute the request)
Simon
On Tue, Jun 4, 2013 at 5:42 PM, Ted Yu <[EMAIL PROTECTED]> wrote:

> Can you check region server log around that time ?
>
> Thanks
>
> On Jun 4, 2013, at 8:37 AM, Simon Majou <[EMAIL PROTECTED]> wrote:
>
> > Hello,
> >
> > I am using thrift & thrift2 interfaces (thrift for DDL & thrift2 for the
> > rest), my requests work with thrift but with thrift2 I got a error 400.
> >
> > Here is my code (coffeescript) :
> >
> >  colValue = new types2.TColumnValue family: 'cf', qualifier:'col',
> > value:'yoo'
> >  put = new types2.TPut(row:'row1', columnValues: [ colValue ])
> >  client2.put 'test', put, (err, res) ->
> >    console.log 'put', err, res
> >
> >
> > Here is what is sent by the put method :
> >
> > { row: 'row1',
> >  columnValues: [ { family: 'cf', qualifier: 'col', value: 'yoo',
> > timestamp: null } ],
> >  timestamp: null,
> >  writeToWal: true }
> >
> >
> > And here is the reply from thrift2 deamon :
> >
> > receive HTTP/1.1 400 Bad Request
> > Connection: close
> > Server: Jetty(6.1.26)
> >
> >
> > There are no logs into thrift2.log when I do my request.
> >
> > Anyone have any clue ?
> >
> > Simon
>