Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive >> mail # dev >> Review Request 14891: Stats


Copy link to this message
-
Re: Review Request 14891: Stats

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/14891/#review27821
-----------------------------------------------------------

trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java
<https://reviews.apache.org/r/14891/#comment54102>

    I think newDir is a better name for this variable.
    

trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java
<https://reviews.apache.org/r/14891/#comment54113>

    minor nit - java for-each loop is more readable.
    

trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java
<https://reviews.apache.org/r/14891/#comment54104>

    This is a duplicate of containsAllFastStats function.
    

trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java
<https://reviews.apache.org/r/14891/#comment54223>

    can you add a function comment, say - "check if statistics needs to be (re)calculated"

trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java
<https://reviews.apache.org/r/14891/#comment54116>

    minor edit to comment, change " if new and old have different stats" to " if new and old have different 'fast' stats"

trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java
<https://reviews.apache.org/r/14891/#comment54115>

    I think getStatsFastCollection mgith be a better name for the function. Also that will be in line with how it is referred in rest of the code.
    

trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java
<https://reviews.apache.org/r/14891/#comment54121>

    Should we have a null and empty string check before passing the stats value to Long.parseLong ?
    Otherwise it will throw a NumberFormatException.

trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java
<https://reviews.apache.org/r/14891/#comment54222>

    As this is not being used anymore we should remove it.
- Thejas Nair
On Oct. 23, 2013, 10:21 p.m., Ashutosh Chauhan wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/14891/
> -----------------------------------------------------------
>
> (Updated Oct. 23, 2013, 10:21 p.m.)
>
>
> Review request for hive.
>
>
> Bugs: HIVE-3959
>     https://issues.apache.org/jira/browse/HIVE-3959
>
>
> Repository: hive
>
>
> Description
> -------
>
> Update Stats while altering table/partition
>
>
> Diffs
> -----
>
>   trunk/hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseStatsUtils.java 1535192
>   trunk/hbase-handler/src/test/results/positive/hbase_stats.q.out 1535192
>   trunk/hbase-handler/src/test/results/positive/hbase_stats2.q.out 1535192
>   trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveAlterHandler.java 1535192
>   trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java 1535192
>   trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreUtils.java 1535192
>   trunk/metastore/src/java/org/apache/hadoop/hive/metastore/Warehouse.java 1535192
>   trunk/metastore/src/test/org/apache/hadoop/hive/metastore/TestHiveMetaStore.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/FileSinkOperator.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/MoveTask.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/StatsTask.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/TableScanOperator.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/vector/VectorFileSinkOperator.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/merge/MergeWork.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/stats/PartialScanMapper.java 1535192
>   trunk/ql/src/java/org/apache/hadoop/hive/ql/metadata/Hive.java 1535192